Where do driver jars live?

Answered

I am not able to download any of the updated drivers (SqlLite, MSSQL, etc) through the datagrip interface.

The issue is likely due to our corporate network policy rules. I can manually download the jar files, could someone please clarify what folder to drop them into on Windows7 x64.  Thank you.

6 comments
Comment actions Permalink

Hi,

E.g. for Postgres `C:\Users\%USER%\.DataGrip2017.2\config\jdbc-drivers\PostgreSQL`.

Thank you.

P.S.: Also refer to our help https://www.jetbrains.com/help/datagrip/connecting-to-a-database.html#vertica_as_unsupported_dbms

0
Comment actions Permalink

Thanks for the response. I manually downloaded the driver and placed it in the directory specified. I am still unable to use DataGrip. 

 

The Test Connection button is disabled and there is a Problems message, "— Download missing Sqlite (Xerial) driver files [Fix]"

 




0
Comment actions Permalink

As a sidebar - We bought licenses, it would be nice if we could get the product to actually work.

 

Also, the instructions that I were directed to at - https://www.jetbrains.com/help/datagrip/connecting-to-a-database.html#vertica_as_unsupported_dbms do not seem to be correct.

 

Step 5 on that page states, "In the JDBC drivers section, click /help/img/idea/2017.2/add.png and select your driver file or files in the dialog that opens." and has the following illustration

However, there does not appear to be a "JDBC drivers" section

 

0
Comment actions Permalink

Hi,

You need to specify your jar file by clicking "+":

Thank you.

0
Comment actions Permalink
  • Howdy, this was a great post just what I needed.
  • Caveat: my corporate entity cleans C:\ at every reboot so how can I move my .DataGrip2019.2 folder from C:\ to say H:\ mounted or shared drive without losing everything?

Thanks!

0
Comment actions Permalink

@David Brown,

You can copy .DataGrip20XX.X folder to your desired location. Then make a fresh install of IDE and on startup just import settings from custom location.

0

Please sign in to leave a comment.