"skipped breakpoint at ... because it happened inside debugger evaluation"

Answered

I am using IntelliJ to debug the source code of Spark, and I found that some breakpoints are skipped "because it happened inside debugger evaluation", how can I disable the evaluations in debugger, then those breakpoints can be working?

3 comments
Comment actions Permalink

i have disabled that `Java-toString object view` but still have this issue.

4
Comment actions Permalink

@Egor Ushakov's comment works for me. Thanks. The comment says as the following:

"sometimes modification happens inside object toString which debugger calls, you can try disabling it in settings:
File | Settings | Build, Execution, Deployment | Debugger | Data Views | Java - toString object view"

-1

Please sign in to leave a comment.