Hive - Method Not Supported


I try to use DataGrip 2017.2.2 to connect Hive with JDBC, test connection was successful but when i try to load schemas it said "Method Not Supported". It's not a hive problem related, because when i try another SQL Client like DbVis it works fine. I already tried to switch from Tx Auto (auto commit) to Manual but still get that error.



was there a resolution to this as I'm experiencing the same behaviour?


I'm running into this error trying to log into a hiveserver2...

This error specifically occurs when I click on the "Options" tab of the "Data Source", which is next to "Schemas" and before "Advanced.

Here are the logs that I see...

4:29 PM Hived: Hadoop Dev
Method not supported.

4:30 PM Hived: Hadoop Dev
Connection to Hived: Hadoop Dev failed.
[ 08S01] Could not open client transport with JDBC Uri: jdbc:hive2://hdp-dev01-n ... more

4:32 PM Hive2: Hadoop Dev
Method not supported.

4:38 PM Hive2: Hadoop Dev
Method not supported.

4:49 PM Hive2: Hadoop Dev
Method not supported.



@Dsidlo Hi,
Could you check solutions mentioned here?
Could you send us IDE logs?

Also, try to enable "Introspect using JDBC metadata":

Thank you.


I do not see the check-box option to "Introspect JDBC Metadata".

I am using...

DataGrip 2017.3.4
Build #DB-173.4301.31, built on January 17, 2018
JRE: 1.8.0_152-release-1024-b11 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.11.6

Check for updates indicates that I have the latest version.



> Check for updates indicates that I have the latest version.
Could you please install JetbrainsToolbox App to manage your installations. The latest version is 2017.3.7

>I do not see the check-box option to "Introspect JDBC Metadata".
Could you attach screenshots of your General and Options tab of your data source settings?


I'm having this same issue.  Testing the connection fails with "Method not supported". 

I can successfully  connect on the same computer using beeline and ./bin/beeline -u jdbc:hive2://x.x.x.x:10000/, so I know it is possible to hit the hiveserver2. 

I'm using the hive-jdbc-1.2.1-standaolone.jar and hadoop-common-2.7.3.jar for the driver.

Did anyone find a solution to the method not supported error?


We're going to introduce Hive support in 2019.1

I think this will be a new level of Hive experience and all old bugs should go away :)



We are going to add native support for Hive in nearest future.

Right now you may connect to Hive using latest 3.1.1 version of driver (see how to add custom driver in Driver section on Connect to database page).

Note that for unsupported database DataGrip uses JDBC metadata in order to show you database contents, and it may not be 100% correct.

We are going to use the same 3.1.1 driver for native support. So if you encounter problems with the driver please submit an issue (also attach logs to an issue if possible), this will help a lot!




Thanks for the quick responses, glad to hear hive support is coming. I'm trying to connect to hive 1.2 ( default that comes with spark). When I use the latest driver you suggested I get an error:

"Required field 'client_protocol' is unset! Struct:TOpenSessionReq(client_protocol:null, configuration:{set:hiveconf:hive.server2.thrift.resultset.default.fetch.size=1000, use:database=default})"

A bit of googling leads me to believe the error is due to version mismatch between my hive client 3.1.1 and hive server 1.2.

I did try the same original jars (hive-jdbc-1.2.1-standaolone.jar and hadoop-common-2.7.3.jar) with dbviz and everything worked flawlessly including table listing and column autocomplete.  This leads me to believe there is an issue with datagrip and not the diver jar.

I'm not sure how to output logs, but I'm using this DG version:

DataGrip 2018.2.4
Build #DB-182.4505.23, built on September 18, 2018
JRE: 1.8.0_152-release-1248-b8 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.2


Hi Bpierson,

We are now working on hive 2 support, but earlier versions will be supported as well (maybe a bit later)

To view logs you should click Help | Show Log in Finder, you'll see idea.log file.

It would be awesome if you send the log to us. You may submit an issue and attach file there or simply send it to


Hi all,

If you see `Method not supported` error while trying to connect to Hive, try to uncheck read-only mode option on Data sources and drivers panel.

Follow issue here:



Please sign in to leave a comment.