intellij 'make generated local variables final' setting not working

Answered

I have the latest version of Intellij ultimate. When I press <ctrl>-<alt>-<v> to insert a local variabel, intellij always adds 'final'. I do not have the  'make generated local variables final' checkbox checked. When I uncheck the final popup when I press  <ctrl>-<alt>-<v> the final is removed, but next time I do  <ctrl>-<alt>-<v> it did not remember I do NOT want final. This is very annoying. Eclipse never injected final, which is much better because the compiler and jvm can determine if it should be final, you should not put this in your code, it also makes your code very ugly.

1 comment
Comment actions Permalink

Works fine for me. Please try with 3rd plugins disabled if you have them installed. If problem remains, file an issue at https://youtrack.jetbrains.com/issues/IDEA with the same code and your File | Export Settings... jar attached.

0

Please sign in to leave a comment.