Box around SQL code

In DataGrip, is there a way to remove the box that appears around SQL statements as you type?

0
9 comments

_File >Settings >Editor >General >Gutter Icons, uncheck Run Line Marker.

0

I think perhaps I wasn't clear about which "white box" I meant. I the window below, there is a white box. I never want that white box to appear.

0

We are talking the same thing. When the cursor is inside a statement or a multi-statement step, DG surrounds the step with a line box. When you hit [ctrl][enter], it will bring up a pop-up asking which statement to execute. In the above example, you could select between the select statement or you could run the whole ctas step.

To turn off that box highlighting:

_File >Settings >Editor >General >Gutter Icons, uncheck Run Line Marker, [Ok],

That should stop it.

0

Sorry, I must be missing something. I have unchecked that box, but I still have the white box around the query:

 

0

My apologies. I am wrong.

I swear that I tested it on Friday, performing the steps I stated, and it had worked. But I just went out there and changed my settings to what I said, and the box is still there. 

I cannot find a setting to turn it of, nor change the line color to the background color to hide it.

0

File -> Settings... -> Editor -> Color Scheme -> Database -> Console -> Statement to execute -> untic "Effects"

You can also change the Effects via the drop-down option list.

BEFORE:

AFTER:

9

Thank you, that is exactly the setting I was looking for!

0

Place the highest voted item on the top of this thread. Thanks.

0

This has been driving me nuts for days and no posted solution anywhere seemed to work, so I poked around for a while and found exactly what I was looking for.

If the solution(s) above do not work for you, then try

Settings → Editor → Color Scheme → General → Injected language fragment → (disable "Bordered" Effect)

Since all of my queries exist as strings inside of PHP, they're considered "injected code fragments" and were therefore marked with a border.

 

I'm currently using intelliJ 2022.3.2, but this is true for all versions going back to mid-2020 (I haven't updated a few of my workstations).

1

Please sign in to leave a comment.