Built in web server is not working

I get either "This site can’t be reached" when trying to open an html file. No server was set up by default. Here are the settings I've tried.



Hi there,

1) So .. do you have a web server (Apache/nginx/IIS/etc) installed on your computer?

Or you referring to the built-in simple web server that WebStorm comes with? If so -- it uses 63342 port (can be checked in Settings/Preferences) ... ad not 80 (default for http) as on your screenshots.

P.S. If you do not use any Deployment entry (e.g. files no need to be copied anywhere) then built-in web server will be used anyway.

2) When using built-in web server .. the URL should contain project name (localhost:63342/PROJECT_NAME_HERE/file.html) in order for IDE to know what project should be served as all projects are served via the same port (so it acts like domain name in proper web server).


Based on the above -- please clarify what URL it/you trying to open when it does not work.

If it all good -- anything interesting in idea.log (Help | Show Log in...)


I am facing the same issue.

Webstorm Version:

WebStorm 2021.2
Build #WS-212.4746.80, built on July 23, 2021
Licensed to *****
Subscription is active until *****.
Runtime version: 11.0.11+9-b1504.13 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Windows 10 10.0
GC: ParNew, ConcurrentMarkSweep
Memory: 1979M
Cores: 12
Non-Bundled Plugins: one.util.ideaplugin.screenshoter (1.7), PlantUML integration (5.5.1)

Step 1: 


Step 2:


Step 3


Norma Mendonca Not sure I understand what the issue has to do with the IDE. Does this URL work if you open your page outside of the IDE? Is your web server (that listens on https://r2-ui:63342) up and running?


The problem is with IntelliJ's built-in server. For whatever reason, the IDE has stopped using the built-in server when I open a project. Clicking the browser icon in the IDE opens the HTML file using it's filepath on disk, not "http://localhost:63342/<pathway>". (So the path in the URL bar looks like this: "C:/users/dynam/IdeaProjects/Design Studio/designer.html"

Attempting to open the HTML file directly in the browser by typing in the path: "http://localhost:63342/<pathway>" returns a 404 Error. It can't find the file because IntelliJ is NOT running the file on the server! I have made no changes to settings or preferences in the last few weeks to cause this change, and based on numerous other reports I'm seeing on various sites, this problem appears to occur at random. Some users have reported that after a few weeks, the problem simply "went away" and the IDE worked normally again. Either way, this is clearly a problem with the IDE software and JetBrains needs to get this fixed. People have been dealing with this issue for years now.

I've wasted over 4 hours tonight trying to fix this crap, all because I can't test a Javascript Fetch command without the IDE's server. CORS policy no longer lets us test files locally without a mock server.  


I haven't ever seen similar reports, please could you share links to the sites mentioned above?

Please make sure that no deployment servers are configured in Settings | Build, Execution, Deployment | Deployment; also, please check if you can reproduce the issue using a brand new project: create a project, add .html file to it, try opening it in browser using the browsers bar in the editor


Experiencing the same issue but on IntelliJ.  It happens on all my projects.  I tried different ports by changing the Settings | Build, Execution, Deployment | Debugger built-in server port.  But always get the error "localhost didn’t send any data - ERR_EMPTY_RESPONSE".  It appears the Built-in web server is not being started - is there a way to check?


Where did you see this error? please share a video recording of your steps plus the idea.log (Help > Show Log in ...)


TLDR; If you can use built in server in a new project, try deleting your .idea folder (after backing up). 

For anyone coming across this in the future, I wasn't able to debug with logs as there were no errors or warnings.

Creating a new project, I was able to use the built in server as normal for a simple HTML file. 

Decided to try resetting the project by (backing up and) deleting the .idea folder, this seemed to work. 

I'm guessing there was an error with a config file. 



Please sign in to leave a comment.