The database tool does not show the whole content of columns with type longtext

Hi,

the message field in our database looks like this:

I found in the here that I need to use the quick document view. But the view looks like the following and I cannot find a way to load the whole 4.8 MB.

I would like  to convince my team that the intellij database plugin is much better than the Mysql Workbench, but with that problem I don't have any chance in doing so. Can you help me?

Thanks

6 comments
Comment actions Permalink

Try Context menu → Edit maximized and report if it doesn't help.

0
Comment actions Permalink

Hi Maxim,

thanks for your quick response. Unfortunately it does not help. Any other idea?

0
Comment actions Permalink
  1. Right-click the cell that contains the LOB of interest and select Save LOB To File.
  2. You can use this setting on your own risk :) Preferences → Database → Data Views → Max LOB Length
3
Comment actions Permalink

Thank you Maxim, the first option works for me for now :) If not I will have a look at the other option

0
Comment actions Permalink

UPDATE december 2018

-------

Save LOB now seems working fine, as it exports the entire field without any size limit.

I'm using PyCharm 2018.3, built on November 20, 2018

 

Hi there,

just wanted to report that the problem is reflected in "Dump to datafile" tools as well.

I have longtext fields (representing json content) truncated when I've exported using JSON-Groovy.json.groovy export script.

It's like the script reads the Max LOB Length setting? It seems the case since it properly dumped json data when I've changed to a bigger value.

Thank you,

d

1
Comment actions Permalink

Hello,

For me adjusting the max LOB worked.

2

Please sign in to leave a comment.