Creating a project with camelcase creates several folders

The name of my project is my-test and when i create a project with that name RM creates a folder for each word.

 Is there a way to deactive this?

 

7 comments
Comment actions Permalink

Hello,

are you using IDEA? Could you please specify which version and what kind of project you're creating.

0
Comment actions Permalink

I'm creating a gem project

Using Bundle gem my_gem it doesn't create subfolders

0
Comment actions Permalink

I got the same structure by running it manually

bundle gem my-gem

 

0
Comment actions Permalink

Yes, but if you use *underscore* it will respect the entire folder. It's annoying that dir split. Should be a way to disable.

0
Comment actions Permalink

If I use underscore RubyMine produces the same structure I get in Terminal (with one folder 'my_gem'). Do you experience different behaviour?

0
Comment actions Permalink

Here I set a clear example

 

0
Comment actions Permalink

Hello,

sorry for the delay. I get the same structure as on your screenshot in both RubyMine and Terminal (because in RubyMine it's created via the same command `bundle gem project_name`)

0

Please sign in to leave a comment.