PyCharm snap package and installation of cython speedup extension

Completed

I've installed PyCharm 2017.3 EAP on my new Xubuntu 17.10 installation and everything was fine until I've decided to install cython speedup extension.

PyCharm showed me this error: error: could not create 'build': Read-only file system

Then, I've tried to build it manually via command line:


$ sudo python3 /snap/pycharm-professional/current/helpers/pydev/setup_cython.py build_ext --inplace

and received same error message:


running build_ext
building '_pydevd_bundle.pydevd_cython' extension
creating build
error: could not create 'build': Read-only file system

I checked mounted devices and voila: 

$ mount | grep snap
/var/lib/snapd/snaps/pycharm-professional_35.snap on /snap/pycharm-professional/35 type squashfs (ro,nodev,relatime)


Any suggestions how can I solve this problem? I really don't want to return to old `installing from tar archive` method. Maybe I should create a ticket in PyCharm issue tracker?

1
3 comments
1

Hello Pheanex

This issue is on the roadmap and should be fixed in one of the next minor releases. 

1

Seems it is still not working See here

JetBrains is advertising its ToolBox App

0

Please sign in to leave a comment.