totally disable spellcheck

Is there a way to completely/totally/absolutely disable spell checking ?  

 

errr ... what on earth is your spell checker kicking in the commit window ?  note the politeness of this comment 

I actually believe that spell checking should ENTIRELY be encapsulated in a plugin (which I would never activate, hoping that Jetbrains dont load the classes and clutter idiotically every keystroke with asinine useless processing)

Do you have an egg in there which could allow me to get rid of this (costly) nuisance ?

25 comments
Comment actions Permalink
Official comment

You can totally disable spellchecker by configuring Typo inspection in IDE settings (Preferences/Settings | Editor | Inspections)

  • If you don't need it at all just disable Typo Inspection
  • If you would like to define the type of contents to be spellchecked just select or clear the Process Code, Process Literals, and Process Comments check boxes.

Please see details in PhpStorm Help


 

Comment actions Permalink

you wished ! those are my settings (spelling is off), also all options are off. I get the same in WebStorm , although WS does seem to have a dictionary that is uses when doing its turned-off typo inspections. 

Obviously PS does not have a dictionary that it uses when doing a turned off inspection : every valid word in my screen shot is flagged as having a typo, and every invalid word passes the so-called inspection (turned off).

This is (at least) a bug.  

  • performing a turned off inspection
  • while performing a turned off inspection, not using a dictionary that would be required for performing the inspection

You are also missing my question, so let me repeat : it is also a design flaw.

1
Avatar
Vladimir Luchansky
Comment actions Permalink

Hi,

Did you disable Spelling in Settings | Version Control | Commit Dialog?

5
Comment actions Permalink

ah ! no i had not, i should have known better. Thus only two bugs remain:

  • apparently no dictionary is being used by you spell check
  • design flaw : spell checking should be a plugin.  

thanks.

3
Comment actions Permalink

This is an unneeded impl...worse that Word's dictionary....when did IJ make themselves a Word processor and why is it as ever unintuitive to disable this nuisance ? Stick to compile warnings and errors by default, please. Also, can you please give hints as to how to disable unwanted 'features'...i searched for everything else but 'typo'

1
Comment actions Permalink

How man, how I can understand you anger and frustration, I am also fighting with the spellchecking, so much time to disable an option that should not be so invasive every where, for comments ok, but in code, really ?

1
Comment actions Permalink

apparently some in their team think its a great idea and others agree  lol

0
Comment actions Permalink

Yeah, it's seems to be a new trend in dev tools (and other domain), you have to search to disable unwanted features.

I was used to search when I needed something, and it seems more logical to me, you want it, you search for it and make some efforts to get what you want, and thus understand how it works, and what it cost to get it.Spring boot is the perfect example of this, "I have scanned you classpath, so I have activated tomcat, jetty, netty, spring security, your data sources ...". And then, when I ask to the young developers I am working with why there is so much threads and/or potential security breaches in their release, they often did not notice it (logs are only decorative, that why we focus on nice banners rather on useful information).

But well, I must be an old fashioned developer, why the hell should we lose time to know how things work when it's so simple to ignore it and rely on tools ?

 

 

 

0
Comment actions Permalink

The stupidity of it all is, well might be a czech thing, dunno, but I use IJ to guide me thru compile errors, and it takes me thru each and every comment and says its an error/warning - for company-based names/words. So stupid for an otherwise FINE IDE.

1
Comment actions Permalink

Please, just add a central setting for completely disabling this. The amount of annoyance it causes in no way outweighs the benefits of having it.

2
Comment actions Permalink

Could you please clarify what's the problem is? I don't see any straightforward examples since the answer was published in 2017.

If it's just spelling in the editor - just disable the Proofreading | Typo inspection at File | Settings | Editor | Inspections.

-1
Comment actions Permalink

Like so many other things, cant you just disable it by default instead of us going thru a myriad of unintuitive options to disable it ?? Pretty ridic to have spell check on comments and variables, IMO.

1
Comment actions Permalink

We don't want to have it disabled by default: people are using it, we can see it in statistics & feedback.

Finding spellchecker isn't that difficult, tbh. If you search for it in settings it would show just one result:

 

To not process variables disable "Process code" checkbox, to ignore comments - disable "Process comments":

-2
Comment actions Permalink

I do not have the same options as you do. Are we using different operating systems?

1
Comment actions Permalink

Dmitry Tronin 

the one that I find most offensive is the commit message window.  Your updates ignore my settings (as your search above by the way) ... and i end up having to re-enter my preferences every time.

I wont comment on users using it ... their call.  As for me (and my team(s) ), this is a totally bogus non-feature. Spell checking should be a plugin, for the users that abide by that dogma.

As for "We dont want ... " well, what can i say.  Pi.. po.. product management and customer attitude

.02

-- Yves

1
Comment actions Permalink

@MDev oh, you're using Rider? The thing is - that's a PhpStorm forum's section, so I assumed you're using it. Yeah, in Rider it's a bit more difficult to find:

I would suggest submitting this either on Rider desk or at their YouTrack page: https://youtrack.jetbrains.com/issues?q=project:%20rider

 

Yves Le Borgne 

Could you please describe the problem with commit message and preferences? Do you mean that "Spelling" checkbox at File | Settings | Version Control | Commit is reset after an update?

 

0
Comment actions Permalink

I can only say that they keep coming back (what i observe) ... ignored (your inference) .

 

1
Comment actions Permalink

Yes, that really sucks when products override your settings during updates, but Update Copyright has never worked for Moi..is there a special setting for that too

0
Comment actions Permalink

rojajet

Could you please clarify what exactly never worked for you in Update Copyright? If it's not working completely - please share your copyright template.

0
Comment actions Permalink

To Avoid Typo

I do this in Intellij Idea community Edition 2022.1,  Hope this will work in (versions >= 2022.1).

Hit shift key twice , in search type Proofreading: Typo then Turn it Off .

0
Comment actions Permalink

Note that searching for the word `typo` in Preferences/Settings search does not show Editor > Inspections > Spelling > Typo in the results.

 

0
Comment actions Permalink

I would like to disable spelling/grammar checking in Git Commit messages, but cannot

I've done everything in this thread and all the checkboxes are disabled.

I still see green lines/inspections in my git commit dialog 8[

Intellij Idea Community 2021.3.1

0
Comment actions Permalink

Have you tried unticking "Spelling" in a "Commit message inspections" section of "Settings/Preferences | Version Control | Commit"? settings window already?

0
Comment actions Permalink

Yep tried that, didn't work

0
Comment actions Permalink

Could you please try to install the latest available build (should be 2022.2.3 by now) and check if it works there?

0

Please sign in to leave a comment.