Prevent Clipboard Search

Answered

Trying to find where I can disable the autofill for searches. Every time I open a search dialog it automatically fills whatever is in the clipboard, so if I search and then copy something to my clipboard it automatically updates the search dialog with whatever is in my clipboard, which isn't what I want. I assume there is a way to turn this off? It's pretty annoying to have to copy my search terms to an external text document because the app is going to change my search and I have to go in and fix it every time I copy any text to the clipboard.

25 comments
Comment actions Permalink

Strange. My version behaves differently. It fills the search with current selection, not the clipboard.

If there's no selection - the search stays the same.

0
Comment actions Permalink

Maybe it's the selection rather than the clipboard. It's just that I search for something, then copy a line of code and go to find a page in the search I just did and the search has been changed and I have to search again in order to find what I wanted (and had already found before the app changed the terms). I just don't want the app changing my search unless I tell it to.

 

1
Comment actions Permalink

Just to get the obvious out of the way: you search with ctrl-f, copy with ctrl-v then you press ctrl-f again?

0
Comment actions Permalink

Would help understand your problem better, if you could record the problem using http://www.screentogif.com/ or something like that.

P.S. Not a JetBrains employee.

0
Comment actions Permalink

You can use "Open in Find Window" button in the bottom right corner to keep the search results from closing.

If you would like to work with different searches, you can enable "Open in new tab" option in the Settings (bottom left corner).

0
Comment actions Permalink

Using shift-cmd-F to search the whole project. I enter code to search, then if I copy something else onto the clipboard and go back to the search window, the search has changed and I have to go back and find the original code so that I can see the results because the app has changed my search to whatever I copied and the old results are gone.

0
Comment actions Permalink

I don't know how to fix your issue.

In cases I know I'll return to results of a search multiple files I usually use "Find in path" on project root, and then click "Open in Find Window" (ctrl+enter), so that no matter that I do, my search results will stay safe in a seperate "Find" tab that you can minimize\maximize when needed.

0
Comment actions Permalink

After some more testing it looks like it is definitely the selection that is replacing the search so if I copy something I guess I just have to make sure I deselect it before trying to do anything else, which is a pain but not as annoying as not knowing how to avoid it at all. It looks like it auto-fills the search with the selection only if it was selected in an open document, not if it is selected in a preview window, so that's a bit odd too. I guess I was hoping that there was a way to either disable that auto-fill feature or to make it so that find in path always opens in a tab, but there doesn't appear to be a way to do either of those.

2
Comment actions Permalink

>not if it is selected in a preview window, so that's a bit odd too.

Well ... if you select something in a preview window and hit shortcut for Find in Path ... it will search for the selection...

>I guess I was hoping that there was a way to either disable that auto-fill feature

AFAIK there is no such option (2017.2.4)

(P.S. I personally love it -- no need to remember copy-paste step -- just select and hit the shortcut)

>or to make it so that find in path always opens in a tab

Could you please clarify on this one -- what exactly you wish to have opened in a tab?

0
Comment actions Permalink

Also note that there's search history in Find in Path window - just click on the magnifying glass icon to access all previous searches if you need to search for something again.

0
Comment actions Permalink

How can I disable this??  It's really annoying.  When I select something and hit cmd-c, cmd-f cmd-v it's double pasted in the find buffer.  Burns me every time.  There needs to be an option for this.  It needs to work like every other Mac editor program in the universe and be different if you want it to be.

2
Comment actions Permalink

Yeah, that gets me a lot too. It's just so instinctual to do that combo quickly that I don't even think about it. Rationally, I understand that just hi-lighting and CMD-F is more efficient but the other way is such a habit, lol. Luckily a quick CMD-A CMD-V will fix it up quick.

I never did find a way to disable the feature. The best solution I found was to not have anything highlighted when I hit search. As long as I remember to do that it doesn't auto-fill at least but would definitely be nice to have the option to turn it off.

2
Comment actions Permalink

I have tried to do it right for over a year, and still screw it up like 20 times a day.  You have to highlight the text to copy it so now I have to remember to unhighlight it before doing a find.  Again - completely counter intuitive to every other editor ever made.  Thanks for letting me know you didn't find anything either.  JetBrains - you need to do something about this.  I've got everyone around the table using your products and absolutely everyone is hitting the same issue. 

1
Comment actions Permalink

That "auto-fill" the search field is super annoying! It doesn't match with behavior of any other app in the system. Idea, please-please add a possibility to disable it. I'll do my own `cmd-v` when needed. I don't need your help with that which actually kills productivity. Thanks in advance :)

2
Comment actions Permalink

Is there any way that we can a build with this disabled??  It continues to screw me up on a daily basis!

1
Comment actions Permalink

+1 Please give users an option to disable this "feature"

1
Comment actions Permalink

Looking for a fix for this as well. I've been trying to get over it for a year now, still mess it up daily.

1
Comment actions Permalink

Posting +1 here wouldn't help. Please submit a feature request to make this feature optional. Similar to https://youtrack.jetbrains.com/issue/IDEA-147128

2
Comment actions Permalink

+1 Yeah, I tried to change, but hell, I'm used to use it the other way,

I came to this post cuz :S

1
Comment actions Permalink

+1 Please make it optional :) It is really annoying.

2
Comment actions Permalink

Yep this hits me several times a day in IDEA as well. Cmd-C, Cmd-F, Cmd-V, it's just muscle memory. It's really important for productivity for apps to conform to the platform UX they're running on.

2
Comment actions Permalink

We need this to be optional. It is a muscle memory... Other apps behave different.

0
Comment actions Permalink

Oh, thanks, adjusted

0

Please sign in to leave a comment.