Incorrect Cursor showing in Editor Window


I'am using PhpStorm 2017.2.4 under Debian 9.2 64bit. In the Editor window, on the left side the 'I' bar is not showing up, instead the default cursor is shown. On the right hand side of the editor, it is shown, but it is also shown when above the scrollbar. I deleted the whole PhpStorm Installation and config and reinstalled it but nothing changes. After deleting the projects .idea folder the problem is gone for 1 hour or 2. After that the Problem reappears. It is like the area where the 'I'-Beam should be shown is shifted to the right hand side. If you like, I can provide Images or the .idea log. What can I do to fix this, do you have a advice for me? 

Thank you




A screencast that сould show what exactly is going on would be appreciated.


Hello Vladimir,

a example: 

I install PhpStorm 2017.4 on a fresh linux system. I work with PhpStorm till late night and everything works fine. I shutdown the computer, and on the next day the cursor in the editor window is screwed up.

Its like PhpStorm thinks there is a Toolbar or something like that instead of text. On the left side I get the default cursor,

when of the right hand side of the editor window its the I-Beam.

Therefore the I-Beam is active while hovering e.g the scrollbar.


If I delete either the PhpStorm-Config or the project config and restart, its gone till the next pc restart. But i need to delete the config completely, when leaving a empty folder, though there is no config in it, the problem still consists. I don't know how to fix it.




Sorry for that, it's a bug, this one and the related one also:

Please vote for both.


I had a similar problem. The area in which the text cursor was being shown and where the default cursor was shown was incorrect.

The problem was fixed just by expanding the window and then maximizing it back to its size, using the window buttons on title bar.

The problem occurs when you close the intellij idea window in an unmaximized state and then restart the IDE. Probably something to do with the IDE or JRE remembering the bounds for cursor. So resizing the window fixes the problem.

Best Regards,



@Sourabh Bhat: Thx, you change my life :)


@Sourabh Bhat Thanks for this, resizing worked for me.


Please sign in to leave a comment.