Main Menu not showing

Answered

Hi everyone, sorry for asking such a silly question here. I have been using the IDEs from Jetbrains for awhile now, but recently, I can't remember what I pressed or did, but the main menu seems to have disappeared. How do I make the menu reappear again? It's also happening to my other Jetbrains IDEs

10 comments
Comment actions Permalink

I have exactly the same issue with appcode!

0
Comment actions Permalink

Also the same problem. 

0
Comment actions Permalink

Looks like we already have this issue in our tracker - https://youtrack.jetbrains.com/issue/JRE-434. Please update the OS to macOS 10.13.2 beta, it should solve the issue. Or you can try the workaround suggested in the mentioned YouTrack ticket.

0
Comment actions Permalink

I had the same issue with intelliJ 2019.2 in windows 10 and to fiw this I had to open the file "c:\Users\[theUser]\.IntelliJIdea2019.2\config\options\ui.lnf.xml" and set the option entry SHOW_MAIN_MENU to true and it fixed my problem!

9
Comment actions Permalink

I had a similar problem, I hid the main menu from "View > Appearance > Main Menu" and couldn't restore it. I managed to restore it by following these steps:

  • Open settings with Ctrl + Alt + S
  • In Keymap, select "Main Menu > View > Appearance > Main Menu"
  • Right click > Assign a shortcut. Entered the shortcut, then OK

Typing the keyboard shortcut now restored the main menu.

19
Comment actions Permalink

This is actually super simple! Click on the search icon (magnifying glass) in the top righthand corner under the X icon. In the search bar, type the word "menu" (no quotes when actually typing it). You should see this result come up:
View | Appearance: Main Menu

And then just click the toggle to change it from "Off" to "On"

That should do the trick!

34
Comment actions Permalink

same problem on ubuntu, double Shift or Ctrl + Shift + A didn't work for me. Trick with "menu" in search didn't work too.

But ctrl + alt + S is open settings and you can create what you need in keymap

0
Comment actions Permalink

Alex, You are genius!!!

0

Please sign in to leave a comment.