I can't accept the License Agreement



I just made a Student Accont yesterday but when I try to acceot the License Agreement the button is grey. Can anyone help me with this issue?


I have the same problem. Tried over and over again, actually read the whole thing, but I couldn't accept the agreement no matter what I did. That is, the button as always greyed out.


Same here... looks like it's a new problem, so we should wait.


Same here. Sucks


Try it with another webbrowser per example IE under windwos. I had the problem with chrome.

Vladimir Luchansky

Maybe adblock or some other extension could affect that?


Worked with Firefox <3


I had the same problem in chrome, tried safari and it worked first time.


Having the same problem - tried firefox, chrome and edge. None worked.


Could you please check if you have a JavaScript enabled?

This page can show it to you: https://www.enable-javascript.com/


I have a little solution, but is a little convencional, because you will have to change html code from web browser in the submit button tag where it is "disable = true", you must erase this part and accept button is active. Sorry for my horrible English.


Try to scroll down to the end of the License Agreement.


And after reaching the end, still the [accept] button is grayed out, then you need to resize the window, and voila!


Happy coding


Embarrassing how years later this still isn't fixed (or even looked at). I had to do what Guerra suggested. Right click on the  button using Chrome, and select "Inspect". Then home in on the button. Rip out the "disabled" part. And that still didn't work. I had to scroll and resize the window a bit, and then, the button actually worked. So, should I file a bug report stating that normally you can't enter the bug system unless you hack it? Must be a pretty lean reports coming in lately...

Possible workaround: use Android Studio and mess with gradle.build file to overcome the differences. You can run local Java applications using it.


just resize the licence agr. window it helps!!! 


its a shame that there is no resolution to this issue.

after some poking if you manage to go to next window i.e "Intellij IDEA License Activation" it is still a blank screen.


Logs from the profiler

17.03-66 0.002: Log file: /home/sm/.yjp/log/Main-9294.log
17.02-66 0.002: Command line:
17.02-66 0.002: Executable: /home/sm/ideaj/ideaIU/jre64/bin/java
17.02-66 0.002: uname:
sysname: Linux
release: 4.17.3-200.fc28.x86_64
version: #1 SMP Tue Jun 26 14:17:07 UTC 2018
machine: x86_64
17.02-66 0.002: Linux; fast_thread_cpu_time=1; 64-bit process
17.02-66 0.002: hid: 36022947459924U8Y78YV33Y24848Y56W6 64-bit machine
17.02-66 0.002: Today is 20180701
17.02-66 0.002: full_build_stamp: 2017.02.66 201709051529
17.02-66 0.002: Agent library path: /home/sm/ideaj/ideaIU/bin/libyjpagent-linux64.so
17.02-66 0.002: getTimeNsInfo: "monotonic_raw"
17.02-66 0.002: Agent_OnLoad: orig_options=delay=10000,probe_disable=*
17.02-66 0.002: phase: 1
17.02-66 0.002: jvmtiVersion: 30010203
17.02-66 0.002: vendor: JetBrains s.r.o
17.02-66 0.002: version: 25.152-b39
17.02-66 0.003: info: mixed mode, sharing
17.02-66 0.003: isJava6: 0
17.02-66 0.003: session_id: 39918956533582 (1530484558,9294)
17.02-66 0.012: line_method: 1
17.02-66 0.060: Reusing existing jar file: /tmp/yjp201709051529.jar
17.02-66 0.066: JVMTI 30010203; 25.152-b39; JetBrains s.r.o; mixed mode, sharing
17.02-66 0.118: Successfully registered probes: 1
Registered: .AgentLoadingSupport
17.02-66 0.531: agentStart: 1
17.02-66 0.531: agentStart: 2
17.02-66 0.532: agentStart: OK
17.02-66 0.758: tracing=off: large method: 3945 sun.nio.cs.StandardCharsets$Aliases.init(java.lang.Object[])
17.02-66 1.378: vmInit: 1
17.02-66 1.387: vmInit: 2
17.02-66 1.387: agentInit: 1
17.02-66 1.389: agentInit: Core loaded
17.02-66 1.417: setTriggers:

17.02-66 2.102: setTriggers: to unregister: 0
17.02-66 2.103: setTriggers: method listeners to register: 0
17.02-66 2.103: setTriggers: OK
17.02-66 2.103: ourUnsafe: true
17.02-66 2.103: shmem 42341490: OK
17.02-66 2.104: shmem 4234148E: OK
17.02-66 2.326: Profiler agent is listening on port 10001
17.02-66 2.330: *** HINT ***: To get profiling results, connect to the application from the profiler UI
17.02-66 2.330: agentInit: Core.init() called
17.02-66 2.331: socket timeout: 30000
17.02-66 2.342: agentInit: OK
17.02-66 2.342: vmInit: 3
17.02-66 2.342: onStartProfiling: entering...
17.02-66 2.342: onStartProfiling: done
17.02-66 2.342: vmInit: OK
17.02-66 2.795: SP: pin java.lang.ClassNotFoundException
17.02-66 3.679: tracing=off: large method: 2252 jdk.internal.org.objectweb.asm.Frame.execute(int, int, jdk.internal.org.objectweb.asm.ClassWriter, jdk.internal.org.objectweb.asm.Item)
17.02-66 4.619: SP: pin java.lang.NoSuchFieldError
17.02-66 4.619: SP: pin java.lang.NoSuchMethodException
17.02-66 5.180: SP: pin java.io.FileNotFoundException
17.02-66 5.180: SP: pin java.security.PrivilegedActionException
17.02-66 6.404: [m: 3154 72] total classes: processed=1000 instrumented=904 1654ms
17.02-66 7.485: warning: resulting bytecode is too long, trying a fallback: a/g/cb a0 ()V
17.02-66 7.575: warning: cannot instrument method because resulting bytecode is too long: a/g/cb a0 ()V
17.02-66 7.575: warning: bytecode too long after T&A: a.g.cb
17.02-66 8.666: tracing=off: large method: 3793 com.sun.crypto.provider.SunJCE$1.run()
17.02-66 8.750: tracing=off: large method: 7690 com.sun.crypto.provider.DESCrypt.expandKey(byte[])
17.02-66 8.943: tracing=off: large method: 3191 sun.awt.resources.awt.getContents()
17.02-66 9.069: SP: pin java.lang.NumberFormatException
17.02-66 9.590: SP: pin org.apache.xerces.xni.parser.XMLConfigurationException
17.02-66 9.599: SP: pin org.xml.sax.SAXNotRecognizedException
17.02-66 9.616: tracing=off: large method: 3208 org.jdom.Verifier.isXMLLetter(char)
17.02-66 9.639: SP: pin org.apache.xerces.impl.XMLEntityScanner$1
17.02-66 9.806: [m: 3222 207] total classes: processed=2000 instrumented=1822 1974ms
17.02-66 10.355: SP: pin java.lang.ArrayIndexOutOfBoundsException
17.02-66 10.463: tracing=off: large method: 2150 com.intellij.openapi.application.impl.ApplicationInfoImpl.loadState(org.jdom.Element)
17.02-66 10.615: tracing=off: large method: 2454 javax.swing.SwingUtilities.computeDifference(java.awt.Rectangle, java.awt.Rectangle)
17.02-66 10.666: tracing=off: large method: 12087 javax.swing.plaf.metal.MetalLookAndFeel.initComponentDefaults(javax.swing.UIDefaults)
17.02-66 10.671: tracing=off: large method: 15361 javax.swing.plaf.basic.BasicLookAndFeel.initComponentDefaults(javax.swing.UIDefaults)
17.02-66 10.731: tracing=off: large method: 2494 java.awt.event.KeyEvent.getKeyText(int)
17.02-66 10.732: [m: 3231 220] total classes: processed=3000 instrumented=2701 2240ms
17.02-66 10.814: tracing=off: large method: 4108 sun.text.resources.FormatData.getContents()
17.02-66 10.836: tracing=off: large method: 8619 sun.util.resources.CurrencyNames.getContents()
17.02-66 10.938: tracing=off: large method: 10921 com.sun.java.swing.plaf.gtk.GTKLookAndFeel.initComponentDefaults(javax.swing.UIDefaults)
17.02-66 11.095: SP: pin java.awt.FontFormatException
17.02-66 11.452: tracing=off: large method: 7044 javax.swing.plaf.synth.SynthStyle.populateDefaultValues()
17.02-66 12.052: SP: pin java.lang.NoSuchMethodError
17.02-66 12.629: SP: pin java.lang.NoSuchFieldException
17.02-66 12.908: [m: 3356 257] total classes: processed=4000 instrumented=3592 2656ms
17.02-66 12.922: GCPauseCounter: installed to ParNew
17.02-66 12.922: GCPauseCounter: installed to ConcurrentMarkSweep
17.02-66 13.621: tracing=off: large method: 3206 java.awt.image.ComponentColorModel.getDataElements(int, java.lang.Object)
17.02-66 13.622: tracing=off: large method: 2118 java.awt.image.ComponentColorModel.coerceData(java.awt.image.WritableRaster, boolean)
17.02-66 14.252: tracing=off: large method: 2978 java.awt.GridBagLayout.GetLayoutInfo(java.awt.Container, int)
17.02-66 14.460: tracing=off: large method: 2604 com.intellij.ui.components.JBScrollPane$Layout.layoutContainer(java.awt.Container)
17.02-66 14.628: SP: pin java.lang.IllegalArgumentException
17.02-66 15.022: SP: pin java.lang.UnsatisfiedLinkError
17.02-66 15.087: [m: 3366 274] total classes: processed=5000 instrumented=4479 3054ms
17.02-66 16.085: tracing=off: large method: 2317 sun.security.ssl.ServerHandshaker.clientHello(sun.security.ssl.HandshakeMessage$ClientHello)
17.02-66 16.538: SP: pin java.io.IOException
17.02-66 16.538: SP: pin java.security.cert.CertificateParsingException
17.02-66 16.727: SP: pin java.lang.UnsupportedOperationException
17.02-66 16.762: tracing=off: large method: 3852 com.sun.crypto.provider.AESCrypt.decryptBlock(byte[], int, byte[], int)
17.02-66 21.900: SP: pin javax.crypto.AEADBadTagException
17.02-66 21.901: SP: pin java.lang.IllegalStateException
17.02-66 31.877: tracing=off: large method: 4821 sun.nio.cs.ext.ExtendedCharsets.<init>()
17.02-66 31.942: SP: pin java.nio.charset.UnsupportedCharsetException
17.02-66 32.106: vmDeath: 1
17.02-66 32.106: vmDeath: 2
17.02-66 32.107: vmDeath: 3
17.02-66 32.107: vmDeath: 4
17.02-66 32.107: vmDeath: OK


Guys who reported the issue lately, could you please confirm if it's still about the browser EULA issue, or about the license agreement in the product (when you start PhpStorm/IDEA/whatever)?

Soumit, please show a screenshot of what you see. I've seen that recently with the proxy auth dialog, it wasn't clickable and you could only force-kill the product. Is the situation the same for you?


Attached screenshot as advised. I am facing this issue with Intellij/IdeaIU.../bin/idea.sh  

Installation attempt on Fedora27 workstation



You must updale your jetbrains toolbox.

Vladimir Luchansky

@Soumit Saha Is anything written into ~/.IntelliJIdea2018.1/system/log/idea.log?


I'm getting same issue as Pajdal97

When I run idea.sh after installing to /opt/ I get a blank License Agreement window

Debian 64 running KBE

Vladimir Luchansky

Please try to run idea.sh as su - will the issue remain?


Ok, did some more on this last night.

If I do this via an RDP session to KDE and try to run idea.sh from an su then it falls over with an X11 connection exception (kinda expected).

However, I run from a console session in KDE then all is sweet and good; I dont have to elevate to run under su.

Console (local) KDE session:- All good, Idea runs sweetly

RDP (Xvnc) KDE session (Non elevated user):- Blank windows

RDP (Xvnc) KDE session (su user):-  java.awt.AWTError: Can't connect to X11 window server using ':10.0' as the value of the DISPLAY variable.  (Probably as expected as the su session will not be the X11 based session)

Hope that helps.  I'd really like to be able to run Idea from a remote KDE session rather than having to run locally.  Guessing it will be a setting somewhere but I'm not up to speed on X11/KDE and graphical stuff yet :-)


The simplest solution to the grayout [Accept] button is "Resize" the policy window. Just click and drag the buttom of the window it will automatically ungray the [Accept] button.


In case folks stumble across this thread like I did, I managed to resolve this by adjusting my maximum color depth to 24 bits vice 32 in my /etc/xrdp/xrdp.ini file (set max_bpp=24). That resolved the blank windows issue and allowed me to use PyCharm over an xrdp connection.


Ran into the same issue (greyed-out Accept button) on a Mac.  Got past it by increasing the size of the window (thanks, Saliufreddy).  Unbelievable that this was reported a year ago and still hasn't been addressed in the current download.


For those of you experiencing this issue in ubuntu, you can do it manually by copying to following file to this location:



<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<!DOCTYPE map SYSTEM "http://java.sun.com/dtd/preferences.dtd">
<map MAP_XML_VERSION="1.0">
<entry key="eua_accepted_version" value="1.1"/>


Also, just in case, a similar ticket:


(it could be non-obvious at the first glance but the "I confirm..." string has no checkbox and _clickable_ itself)


I was having this issue on (chrome for Android mobile). But I enables the desktop site in the menu and all was well


Funny thing that i have to use IE to open the url, continue button can click after that, when i login into teamcity and got warning IE is not support please use Edge.lol


When you run into this problem, hit escape.

This will take you to a new page stating you cannot install without agreeing.

You will now have  a YES or NO option.

The No will be highlighted in red, simply use your left nav key to highlight the <YES> ,then hit ENTER and install will commence


Please sign in to leave a comment.