12 comments

it's not available in 2019.1 on mac anymore :(

8

Same. Lost from Tools with 2019.1 update

2

Any chances that you have installed PhpStorm via snaps / JetBrains Toolbox?

There is a thread about it:

https://youtrack.jetbrains.com/issue/IDEA-206235

0

Indeed, new IDEA was installed by toolbox.

0

I'm using Jetbrains Toolbox for Mac to update the intellij. After updating to 2019.1, opening any project from command-line opens in old version which is 2018.3.

I don't find `Tools -> Create command-line Launcher ` anymore in 2019.1, how do i fix this issue?

Jetbrains Toolbox doesn't allow me to delete old versions (because of rollback option).

2

Can't we simply have Jetbrains integrated with the command-line automatically with any install?

it is kind of sad that with each update we have to go to each of the jetbrains products and trigger this via the menu... at least make it a global setting on the toolbox to install all products with this integration

-- Update --

After posting just checked in the toolbox and they have it :D 

In toolbox go to "Settings -> Generate shell scripts" press to activate  and set the "Shell script location" to /usr/local/bin  or to any other folder wanted

Solved for me, hope it helps others :)  

6

Thanks Ricardo for pointing it out.

I tried using the Jetbrains toolbox to generate the script, but it's so buggy. If pycharm is installed, it never creates a script for intellij (idea) (only creates script for pycharm). If i've multiple versions of intellij, it doesn't work. At worst, it deletes the existing /usr./local/bin/idea file.

 

0

Sriram, please report this at https://youtrack.jetbrains.com/newIssue attaching screenshots illustrating the issue.

0

https://intellij-support.jetbrains.com/hc/en-us/community/posts/115000668350/comments/360000428440

 

same hier. in 2019.1 this option is disabled...

 

WebStorm 2019.1
Build #WS-191.6183.63, built on March 21, 2019
Licensed to <USERNAME>
Subscription is active until July 25, 2019
JRE: 1.8.0_202-release-1483-b39 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.4

 

double SHIFT in editor and write in action tab "launcher".

 

I changed script path in toolbox, but nothing happened:

```

$ webstorm .

The file /Users/<USERNAME>/Library/Application Support/JetBrains/Toolbox/apps/WebStorm/ch-0/183.5912.23/WebStorm.app does not exist.

```

0

Please sign in to leave a comment.