Find in path does not work at all

The "find in path" does not find anything on any project :

The other options ("In project", "module") does works.

Last time I ran to this issue, it was "solved" because I made a new fresh setup of my computer.

I try to invalid the cache, even remove the PHPStorm Installation folder and re-install it, nothing changed.

Thanks for helping, this bug is quite annoying for productivity...

I'm using last version of PHPStorm : 

PhpStorm 2017.2.4
Build #PS-172.4155.41, built on September 15, 2017
JRE: 1.8.0_152-release-915-b11 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.10.0-35-generic

Regards.

5 comments

Hello,

I suppose "docker" directory surely contains some files with "granted" text inside, correct?

In the top right corner there's a filter button - could you check if it is set to "Anywhere" and not to "In comments" or "In string literals"?

0

I notice that the results returned by Find in Path aren't grouped by file now, pretty sure they used to be. Obviously, it's much better when they are ordered by order of file name and then by line within the file.

0

@all 

please try to disable .gitgnore plugin and Invalidate caches after that - would that help?

0

In fact, I came to this page when I noticed that Find (in Project) would only find whole words that matched the search term - so a search for "phpmailer" would not find any instances of "phpmailerNEW" in the code.

Disabling all extensions I wasn't actually using, which would have included disabling the .gitignore plugin, did restore the expected operation. Invalidating caches, by itself, made no difference.

So the .gitignore plugin might have been the cause of my own issue, which was not precisely the same as "not working at all" but could look exactly the same - if the reason you were seeing no results at all could be that all the partial matches were being ignored and there were no exact matches.

0

Please sign in to leave a comment.