Find in path does not work at all

The "find in path" does not find anything on any project :

The other options ("In project", "module") does works.

Last time I ran to this issue, it was "solved" because I made a new fresh setup of my computer.

I try to invalid the cache, even remove the PHPStorm Installation folder and re-install it, nothing changed.

Thanks for helping, this bug is quite annoying for productivity...

I'm using last version of PHPStorm : 

PhpStorm 2017.2.4
Build #PS-172.4155.41, built on September 15, 2017
JRE: 1.8.0_152-release-915-b11 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.10.0-35-generic

Regards.

13 comments
Comment actions Permalink

Hello,

I suppose "docker" directory surely contains some files with "granted" text inside, correct?

In the top right corner there's a filter button - could you check if it is set to "Anywhere" and not to "In comments" or "In string literals"?

0
Comment actions Permalink

I notice that the results returned by Find in Path aren't grouped by file now, pretty sure they used to be. Obviously, it's much better when they are ordered by order of file name and then by line within the file.

0
Comment actions Permalink

I am having the same problem

0
Comment actions Permalink

@all 

please try to disable .gitgnore plugin and Invalidate caches after that - would that help?

0
Comment actions Permalink

In fact, I came to this page when I noticed that Find (in Project) would only find whole words that matched the search term - so a search for "phpmailer" would not find any instances of "phpmailerNEW" in the code.

Disabling all extensions I wasn't actually using, which would have included disabling the .gitignore plugin, did restore the expected operation. Invalidating caches, by itself, made no difference.

So the .gitignore plugin might have been the cause of my own issue, which was not precisely the same as "not working at all" but could look exactly the same - if the reason you were seeing no results at all could be that all the partial matches were being ignored and there were no exact matches.

0
Comment actions Permalink

In my case it was because "Recursively" checkbox was not checked.

0
Comment actions Permalink

@Irfan Blackhawk

>I am tired of this .. Please fix it

Be a bit specific please. Fix what exactly?

Weird hex numbers inserted? Not an IDE issue -- https://youtrack.jetbrains.com/issue/IDEA-185799

 

1
Comment actions Permalink

@AndriyBazanov The same screen comes up every single time I invoke 'Find In Path' dialog.

0
Comment actions Permalink

>The same screen comes up every single time I invoke 'Find In Path' dialog.

With hex numbers? Not an IDE issue at all. Check comments in the aforementioned ticket for a solution.

1
Comment actions Permalink

It happens in all of JetBrains IDE's on my machine...

0
Comment actions Permalink

>It happens in all of JetBrains IDE's on my machine...

So..?

I do not want to sound rude or something .. but you with your limited information (the way how you respond) it's not clear if you have checked that link or not .. or perhaps you are even talking about different things now...

1) If you are talking about Hex numbers in Find in Path dialog -- it's NOT an IDE issue

2) Based on reports it happens on Mac OS and the reason for that is a 3rd party software: GPG or Open PGP.

3) Reason (global shortcut that is handled by GPG/Open PGP) and the solution on how to disable that is explained in the aforementioned ticket. In case if you having issues reading through the comments there, here they are:

 

If that does not apply to you (or you are talking about completely different thing), then please explain that in details/with pics, ideally in new thread (to not to mix different things here).

1
Comment actions Permalink

 

typing -> finding

copy or (block & ctrl+shift+F) -> Nothing to show

0
Comment actions Permalink

@Hjloquens20, does it stay that way after File | Invalidate Caches / Restart | Invalidate and Restart?

If it does, please try disabling all custom plugins (Settings/Preferences | Plugins | Installed | Downloaded) and check how it goes afterwards.

If nothing helps, please submit the logs bundle (Help | Compress Logs) within a support ticket.

1

Please sign in to leave a comment.