MacBook PRO 2017 - Editor is laggy (2017.2.4 Ultimate)

Answered

Performance is unbearably choppy, every code validation, autocomplete suggestion, problem resolution suggestion etc... put's a second worth of lag (freeze), like nothing is indexed, I've tried assigning 2gb of ram to heap, doubled the size of every other memory - still choking. And it is only on macbook pro (has 16gb of ram, ssd, i7 cpu and all that). Even a bare minimum template project has these hick'ups, and it really is breaking workflow. It is faster for me to remote into my desktop PC and work like that rather then locally.

6 comments
Comment actions Permalink

I've uploaded IU-172.4343.14_mantasdomasevicius_08.11.2017_15.44.51.zip to the ftp. I was just pasting in JSX import into code which froze editor for a second after pasting, and then froze during selection and part of import deletion.

0
Comment actions Permalink

Have you tried to disable custom plugins ("Preferences | Plugins" show: Custom)?

0
Comment actions Permalink

I have,

It still stutters whenever autocomplete list is being generated ,or suggestion for a code warning is due to pop-up when you hover cursor over it or any other syntax check is being performed, whether it's JS or Java or Groovy or Kotlin. Even when executing say Unit tests, IDEA just freezes up for several seconds until it continues.
I am running IDEA on i7-6700HQ with 2GB of xmx, with almost no plugins enabled. Have 16GB of RAM.
I feel like 2.6GHz just does not cut it. Same codebase with extra plugins on i7-7700k CPU with less XMX dedicated to Idea runs extremely smooth, no stutters, freeze-ups.

So now I don't know if this is a weak CPU or Idea or the fact that it's MacOS :/

0
Comment actions Permalink

Please try with https://confluence.jetbrains.com/display/IDEADEV/IDEA+2017.3+EAP version.

If it's still slow, submit a performance problem at https://youtrack.jetbrains.com/issues/IDEA with the new CPU snapshot and the logs directory zipped. Thanks.

0

Please sign in to leave a comment.