PhpStorm not showing some files on File Search

Some of my project files are not showing up when I try to find them on File Search, but they show up when being searched using Class Search.
Here's an example of a file that shows up on both searches:

And here's an example of a file that only show as Class:

I used Global Search (double shift) to better illustrate, but the same thing happens when using Class and File search individually.

Any ideas?

System:

  • Ubuntu 17.04
  • PhpStorm 2017.2.4
8 comments
Avatar
Vladimir Luchansky
Comment actions Permalink

Hello,

So there are same set of files for SqsClient? Like *Metadata.php, *Stats.php, *Interface.php and others?

What happens if you enter full file name into search field?

0
Comment actions Permalink

Those *Metadata.php, *Stats.php, *Interface.php files are external libs/vendor files and not related to the ones located in my namespace.

Typing the full file name would result in the same behavior: Some files showing as files and classes, others showing only as classes.

By the way, I somehow managed to fix this issue by un-marking my source folder as Source Folder and then marking it as Source Folder again.

A workaround for this issue would be always using double shift, but there's a known bug on linux where the cursor doesn't focus the input when you double shift. :(

0
Comment actions Permalink

I've been experiencing this as well with the file search dialog (cmd + shift + O). Most files show up but it seems the one I'm looking for is constantly missing after recent updates. I figured this was something I was imagining or was isolated to something dumb I had done, but a buddy mentioned it as well so I'm thinking there's something else going on.

 

0
Comment actions Permalink

Workaround.

File | Invalidate cache / Restart

I was having the same issue, was gonna comment on this post and tried the above.
Now The files show up.

Newly added files in project like doing a git pull adds new files in project but doesn't gets indexed and doesn't show up in search.This should get fixed efficiently.

 

 

12
Comment actions Permalink

Just upgraded. Having the same issue.

0
Avatar
Vladimir Luchansky
Comment actions Permalink

Currently there are issues with .ignore plugin - if you have it installed and enabled, please disable and check how it will go afterwards.

0
Comment actions Permalink

Same issue on Intellij IDEA, even after latest upgrade. Will try disabling .ignore

0
Comment actions Permalink

THANKS !

now i have to go search files one by one !!!

0

Please sign in to leave a comment.