Can't get the latest Pug(Ex-Jade) Plugin

I am on PHPStorm 2017.2.4.

When I search for plugins, I get Pug (ex-Jade), but it only shows version 172.2656.13, which based on this page: https://plugins.jetbrains.com/plugin/7094-pug-ex-jade-? indicates that it was released on Jun 2, 2017. However, they have a build for October of this year (173.3188.31), but I cannot install it.

When I attempt to download the ZIP and install manually, PHPStorm indicates: "Plugin 'Pug (ex-Jade) is incompatible with this installation".

0
4 comments

Hi there,

That's correct  -- that is the latest plugin version that is compatible with your IDE.

For 173.xxx build you have to use PhpStorm 2017.3 .. which is currently still in EAP stage.

2

Use "Help | About" in PhpStorm -- it has build numbers there so you can compare them manually if needed. Considering that each version uses different branch (e.g. 172 for 2017.2; 173 for 2017.3 EAP) it should be good enough indication to see if plugin is compatible.

But in general -- just use what's available via "Settings/Preferences | Plugins" -- it's safest and recommended way of installing plugins. It will list only compatible versions (accordingly to info provided, of course).

2

Ah. OK, thanks Andriy.

As a suggestion, on the page I linked above, they can put a little mark next to versions which are EAP so that people who have downloads for only stable versions (like myself) don't get confused in the future. That or maybe make the versions links to a page which indicates which versions are currently EAP, beta, stable, etc. Just spitballin here. :)

Either way, my 1 year renewal is coming up and I'm happily putting in for the next round. I've been very happy with PHPStorm! Keep up the great work! This is the best editor around by a long shot!

0

Good to know!.

0

Please sign in to leave a comment.