Terminal is non functional on Windows 7, using latest Webstorm

Can't type anything into terminal, in webstorm's terminal on windows 7

 

WebStorm 2017.2.5
Build #WS-172.4343.25, built on October 20, 2017
Licensed to WebStorm Evaluator
Expiration date: November 30, 2017
JRE: 1.8.0_152-release-915-b12 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Windows 7 6.1

10 comments
Comment actions Permalink

Please provide a screenshot of Settings | Tools | Terminal page and your idea.log (https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files)

0
Comment actions Permalink

 

 

I'm not sure what part of the log you want, I see an error here though

2017-10-31 12:42:29,872 [ 20578] ERROR - terminal.emulator.JediEmulator - Error processing OSC 0;
2017-10-31 12:42:30,116 [ 20822] INFO - son.PackageVersionRangeMatcher - Matching 37 done in 2197 ms, not matched: []
2017-10-31 12:42:31,547 [ 22253] INFO - .diagnostic.PerformanceWatcher - Indexable file iteration took 7543ms; general responsiveness: ok; EDT responsiveness: 2/8 sluggish, 2/8 very slow
2017-10-31 12:42:31,549 [ 22255] INFO - indexing.UnindexedFilesUpdater - Unindexed files update started: 2 files to update
2017-10-31 12:42:32,043 [ 22749] INFO - .diagnostic.PerformanceWatcher - Unindexed files update took 494ms; general responsiveness: ok; EDT responsiveness: ok
2017-10-31 12:43:42,399 [ 93105] INFO - ide.actions.ShowFilePathAction -

0
Comment actions Permalink

Please provide the whole idea.log file (put it on some file server and let me know the link)

0
Comment actions Permalink

weird... Do you have any 'AutoRun' commands configured in your registry, so that the certain commands are executed each time you start cmd.exe? 

0
Comment actions Permalink

I just installed brand new webstorm, and I couldn't use the terminal

0
Comment actions Permalink

Please see my question above... 'AutoRun' commands have absolutely nothing to do with WebStorm installation, installing/re-installing WebStorm doesn't affect them in any way

0
Comment actions Permalink

You're going to have to be more specific, because command prompt seems to work fine outside of webstorm, it's what I'm doing at the moment to bypass this glitch. 

I'm seeing similar behavior when using powershell in webstorm. 

 

0
Comment actions Permalink

Similar issue is tracked as https://youtrack.jetbrains.com/issue/IDEA-180993, please follow it for updates

0
Comment actions Permalink

Hi All,
I've been waiting for this issue and updates for nearly a month.
I've had good success with webstorm on mac for personal laptop.

I was hoping to promote this product here at work. Seeing that webstorm is facing issues on Windows 7, and the lack of support I'm having second thoughts, and may look at alternatives. 

0

Please sign in to leave a comment.