Markdown editor requesting authorization?

Answered

Whenever I type something inside a .md file I get the following warnings:

Page 'http://localhost:63342/a…w/scripts/processLinks.js' requested without authorization, 
you can copy URL and open it in browser to trust it.
Page 'http://localhost:63342/a…cripts/scrollToElement.js' requested without authorization, 
you can copy URL and open it in browser to trust it.
Page 'http://localhost:63342/a…review/styles/darcula.css' requested without authorization, 
you can copy URL and open it in browser to trust it.

When I copy the links via the copy URL-button and try to call it in my browser it just says "waiting for localhost" and won't finish the request. What's going an here and how can I fix this issue?

 

 

 

 

7 comments

Could you please attach/upload somewhere & share your idea.log file (Help > Show log in ..) after reproducing the issue?

0

I'm having the same issue in WebStorm 2018.1 (just updated to 2018.1.2 hoping it would fix it.

Following the links results in 404 pages, editing the MD file results in the same popups on every auto save. However no logs are produced. (I deleted the logs, then reproduced the issue, to have a clear log from when the issue starts).

Here are the full logs though: https://pastebin.com/iEH5TWkM

While the solution linked by Joao works (allow unsigned requests), I think it's weird that a built in tool is having such issues and doesn't work "out of the box", even weirder is that the "open x in browser to allow" does not seem to work at all either.  ¯\_(ツ)_/¯

0

Well it works out of the box, but unfortunately some users are bumping into that issue.

There's related bug report opened currently: https://youtrack.jetbrains.com/issue/RUBY-20617 - feel free to cast your vote or add some info in comments section.

1

there is the answer : Settings -> Build, execution, development -> Debugger - >Allow unsigned request

2

Thanks Ksgilove0, You save my day ! I'm facing this issue for a long time and it's really made me angry sometimes.

0

Please sign in to leave a comment.