Automatic upload: check for related changes from File Watchers took to much time and was cancelled

Hi,

I use the newest PhpStorm with the SCSS File Watcher. The SCSS-Files are compiled correctly into the right folder. But the CSS-File are not upload. I get the message

'Automatic upload: check for related changes from File Watchers took to much time and was cancelled'. 

This message is new. A few days ago everthing was fine.

I checked 'Upload external changes'. 

The files should be uploaded on explicit save action. When I save the file after compiling the upload is fine.

 

Regards

Rober

10 comments
Comment actions Permalink

What IDE version are you running? Did you try an OS restart?

0
Comment actions Permalink

I'm having the same problem with the latest version 2018.3 on Windows 10.

Any solution?

It's somewhat annoying to have to manually upload my compiled css.

0
Comment actions Permalink

File | Settings | Build, Execution, Deployment | Deployment | Options > do you have "Skip external changes" checkbox enabled? We would appreciate more info about your project & deployment settings

 

0
Comment actions Permalink

Same problem. 2018.2.4 on Windows 10. What specific information would you like?

I don't believe there is a "Skip External Changes" option.

I have "Upload external changes" checked. 

 

0
Comment actions Permalink

Here was my fix. Hope this helps someone else. 

2018.2.4 on Windows 10

I was using Ruby Sass. I switched to native Node-sass and the compiling is much faster and I avoid the 'Automatic upload: check for related changes from File Watchers took to much time and was cancelled' error.

If you want to install the native Node-sass on Windows, you need to install node-gyp prerequisites first, or when you "npm install node-sass" - it will just bind to your Ruby Sass version again. 

Directions for installing node-gyp prerequisites at: https://github.com/nodejs/node-gyp#on-windows
(you do not have to install the actual "node-gyp" - just the prerequisites)
Find "On Windows" on that page and use "Option 2". (I ran into looping bugs for Python installation when using "Option 1")

Once prerequisites are installed, open Command Window in Administrative mode and run "npm install node-sass"

This should then install node modules under something like: "C:\Windows\System32\node_modules\"

Then I changed my PHPStorm File Watcher Settings from:

Program: C:\Ruby22-x64\bin\scss.bat
Arguments: --no-cache --update $FileName$:$FileNameWithoutExtension$.css
Output Paths: $FileNameWithoutExtension$.css:$FileNameWithoutExtension$.css.map
Working directory: $FileDir$

TO:

Program: C:\Windows\System32\node_modules\.bin\node-sass.cmd
Arguments: $FileName$ $FileNameWithoutExtension$.css --source-map true
Output Paths: $FileNameWithoutExtension$.css
Working directory: $FileDir$

(using "--no-cache --update" prefix did not work for new native version, I guess it's not needed.)

0
Comment actions Permalink

Dave, thank you for sharing the detailed solution for your scenario.

0
Comment actions Permalink

@dave thanks for your answer. I ended up (before reading this) just using gulp-sass externally and ditching the internal file-watcher altogether. It takes less than a second to compile a giant file including bootstrap, fancybox, font-awesome 5, etc..

Your solution is keeps it in PHPStorm which is nice so I might try that. 

0
Comment actions Permalink

I have now noticed one bug with my solution - It seems this works well but does not create a sourcemap file. Or if it does, I do not know where it is. This makes it impossible to use Chrome development sourcemap feature. 

If someone knows how to enable sourcemaps to be created, please let me know. Thanks!

UPDATED: put  "--source-map true" in Arguments

0
Comment actions Permalink

Thank you Andriy!!
Now I know how to set options for this. Works great now.

0

Please sign in to leave a comment.