2017.3 JavaScript debug session opens wrong window

I upgraded to 2017.3 and JavaScript debugging isn't working as expected anymore.  With previous versions a new session would open in a normal Chrome window, with all my bookmarks and cookies present.  2017.3 opens a window which doesn't seem to be associated with my Chrome profile: no bookmarks bar, no cookies, no saved passwords, etc.

Is it a bug or a "feature"?  In the latter case, is there a way to return back to the original behavior?


1 comment

In 2017.3, Chrome extension is not used for debugging by default - see https://blog.jetbrains.com/webstorm/2017/10/webstorm-2017-3-eap-173-3415/. Chrome protocol with --remote-debugging-port option is used instead. Debugging session is started in a new window and using custom profile because it's required to run chrome with --remote-debugging-port argument, and a port for debugging can't be opened after browser is started.

If you like to debug with extension, as before, please enable Update application in Chrome in Preferences | Build, Execution, Deployment | Debugger | Live Edit

See also https://www.jetbrains.com/help/webstorm/2017.3/debugging-javascript-in-chrome.html, Starting a debugging session with your default Chrome profile


Please sign in to leave a comment.