Docker SDK could not produce Remote SDK credentials

I always get that error with all the tools in all the projects where i use any ruby docker image. With docker-compose remote the same images work with the Run tool, but not with the debugger (object of another post).

However, the simplest example is: take a vanilla ruby:latest as the docker image, use it as Remote SDK for an empty project, select it. Now Tool > IRB Console...

You get that error. Am I missing anything?

Is that image supposed to be run automatically in a container by RubyMine or should I do it manually? Tried but no luck.

Comment actions Permalink


what RubyMine version do you use? There was a similar issue but it has been fixed:

Comment actions Permalink

I use the latest just updated. 2017.3. It was the same also on the previous (I believe the RC2).

The log is full of warnings like the following:

2017-11-30 15:50:37,946 [ 459651]   WARN - brains.plugins.ruby.gem.GemBox - Unable to find lib directory /home/dd/.RubyMine2017.3/system/ruby_stubs/1089357486/-1480059672/../lib/ruby/2.4.0for Remote: ruby-2.4.2-p198 (5): ver.2.4.2p198 ( revision 59899) p198 (docker://ruby:latest//usr/local/bin/ruby) 

Recreating the SDK or using another, doesn't remove the warning, it might change the 2 numbered dir in the middle but the result is the same.

That doesn't look normal: either is some sort of misconfiguration on my side (but i even removed the /home/dd/.RubyMine2017.3 and re-imported the settings) or it i a bug.

However, trying to run Tool > bundle > install, it does install. If you run it again, it installs again. Looking at the Docker plugin window, it looks like it creates a new container every time, it runs it, installs, and closes the container

A problem may be that the remote UI allows only to set the remote as an image (not a container). That means that the image is supposed to contain everything, so it is normal that it installs again, since it does not commit the installation.

Is the vanilla ruby:latest image supposed to work as it is or not? Irb should work without any addition, right?

Comment actions Permalink

And the link you posted: yes! That happens to the 2017.3 too! I have the same warnings, and not just for the docker-compose remote, but also for docker remote. Might that be the reason I can run the console but cannot run the debugger console?

Comment actions Permalink

Have you tried without: 

  stdin_open: true
tty: true

in the docker-compose.yml?


Please sign in to leave a comment.