14 comments

Downloading and installing 2017.3 seemed to have worked at first. Now I got an out of memory exception and the program is completely unresponsive.

0

Hi,

 

same situation here. Installed last update 10 minutes ago, PhpStorm did not start after the forced restart.

Restarting PC did not help.

0

I was able to get it going by executing C:\Program Files (x86)\JetBrains\PhpStorm 2016.3\bin\phpstorm64.exe from the file explorer but the normal shortcut didn't work and the upgrade process definitely didn't behave as expected (basically after agreeing to the upgrade the window closed and it appeared that nothing else was happening).

I am not sure why the directory is \PhpStorm 2016.3\ it has been like that since 2016.3 but the upgrades have always worked since then.

 

0

Thanks Victoria,

executing phpstorm64.exe did the trick, but PhpStorm scheme and all the other settings seems to be set to default values and I don't like it :D

I'm gonna download and install version 2017.2.4 and hope all my original settings are still stored somewhere and will be loaded.

 

 

 

0

Hi there,

You may try downloading and running full installer instead of upgrade (you will have to remove currently installed 2017.3 version though). I'm always using it this way .. and don't really have any issues with launching the IDE (Windows 10 x64 here; using bundled x64 JDK).

As for the settings:

  • If you have used 2017.2.x before -- you may just delete 2017.3 settings folder (for Windows that would be "C:\Users\USERNAME\.PhpStorm2017.3") and on next 2017.3 launch it will ask about importing settings from previous version
  • If you did not used 2017.2 .. but it was 2017.3 EAP builds -- the settings will remain the same
0

After the update, PHPStorm simply does not start for me at all. It shows up briefly in task manager and just exits. No UI, no error, nothing. Reboot did not help. Running the exe directly in the /bin folder is the same - process shows up briefly in task manager, then just disappears. Please help!

0

Same here :(

Also, when I launch it using the phpstorm64.exe, it shows this error:

Plugin Error
Problems found loading plugins:
The following plugins are incompatible with the current IDE build: .ignore

0

I think my first problem was caused by PhpStorm's continued linking to 2016.3 although I was on the latest 2017 version. Using Windows search I also could not find the folder containing the 2017 files. Although in hindsight the location of the 2017 files was kind of a no-brainer.

After installing 2017.3 manually I was able to trace the file back to Program Files. Apparently I had been using 32-bit version of 2016 and the 64-bit version of 2017. I don't know if this was what caused the problem initially, but it seems plausible since it was still anchored on the 32-bit version.

The OOM error seems to have been caused by the initial indexing of my project and it's includes, and has not occurred again.

0

>Apparently I had been using 32-bit version of 2016 and the 64-bit version of 2017. I don't know if this was what caused the problem initially, but it seems plausible since it was still anchored on the 32-bit version.

Most likely. When using patch update method new version will be installed into the same folder (which by default includes originally installed version in it's name) and program shortcuts should remain untouched.

As of 2017.1 (AFAIK) IDE comes with 64-bit bundled JDK instead of 32-bit as before. The 32-bit JDK has to be downloaded and installed separately (there is an option for that in actual installer).

Trying to launch 32-bit PhpStorm with no globally installed 32-bit JDK will fail (a specific message should be displayed though).

Using full installer is the best choice in general IMO (regardless of OS used)

1

Definitely something to keep in mind, although it is puzzling why this broke with 2017.3 and neither of its 2017 predecessors

0

Most likely new issue that affects 32-bit JDK only. Here is the ticket: https://youtrack.jetbrains.com/issue/WI-38960

0

I also think this is a 32 bit JDK thing - but note: I did do the full install, including having the installer download the JDK. I switched to my other laptop and the 64 bit installation works fine.

0

This worked for me:

 

1. Reboot your machine

 

2. Go into C:\Users\<PhpStorm folder>\system\tmp

 

3. Delete everything in there

 

4. Start PhpStorm

0

Please sign in to leave a comment.