Hide syntax errors in event log

How do I hide syntax errors in the event log?  I've unchecked a number of items from the event log config, but none of them are called "Syntax Errors" and none of what I unchecked pertains to syntax errors.  Thanks.

5 comments

Hmm... What syntax errors are you talking about? Please provide a screenshot with such error

1

It seems to appear when TS can't compile to JS:

11:54 myProject: Cannot update myFile.js: contains syntax errors

 

I also occasionally see this:

09:04 myProject: Uncaught [object Object]

 

I'm aware of syntax errors in my application, and I don't need them appearing in the event log -- that is not a place for syntax errors (in my opinion).

0

these are not syntax errors, and typescript compiler, as well as the IDE syntax checker, don't log anything to event log.

Please recreate the issue and provide your idea.log (put it on some file server and provide a link here) so that I can see where these messages come from

0

Here's a screenshot.


I can't find idea.log (running Windows)

0

haven't ever seen anything like this. do you have any custom plugins enabled?

see https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files for instructions on locating idea.log

0

Please sign in to leave a comment.