How to prevent syntax checking in markdown files

I have a problem in markdown files - when I describe block as js code like this

```js
... code...

```

IDE produces some errors in js samples which is not correct - it's only sample code in docs

3 comments
Comment actions Permalink

This is by design - Markdown plugin injects the corresponding languages in such blocks (as this is the only way to enable syntax highlighting there), this has been done at users' requests and can't be disabled... See comments in https://youtrack.jetbrains.com/issue/RUBY-18425 for possible workarounds

0
Comment actions Permalink

I dont understand why it's needed to check syntax in markdown - it's markdown file - not js script

1
Comment actions Permalink

It looks like we might be able to disable the syntax check in 2018.3: https://youtrack.jetbrains.com/issue/RUBY-22594

In the meantime, here's a workaround:

  1. Go to Settings > Plugins and search for "markdown".
  2. Disable JetBrains' "Markdown support" plugin.
  3. Click the "Browse repositories" button at the bottom of the settings dialog.
  4. Search for "markdown" and install "Markdown Navigator" by Vladimir Schneider.
  5. Restart your IDE.
0

Please sign in to leave a comment.