After Update iOS 11.2 & XCode , AppCode Build Fail



I solved the problem.

The build was successful in xcode, so suddenly the build in the appcode was successful. I do not know why.


Anyway... Thank you~ :)



I updated iOS 11.2 and Xcode.

and..  AppCode is not working.. build.. clean... 

I can't see any build log..  only... log is below..


AM 9:39 Build failed in 79ms

AM 9:42 Clean failed in 94ms


Does anyone know reason?


Thank you

Official comment

AppCode 2017.3 is fully compatible with Xcode 9.2 (the "unsupported" warning will be removed in upcoming 2017.3.1 EAP). If you have any issues using AppCode 2017.3 with Xcode 9.2, please report them to our tracker, attach idea.log (Help | Show Log in Finder) and build log (from Messages tool window -> Show Build Log). Also it would be great to include information whether you're building the same target & for the same simulator/device as in Xcode (given the build in Xcode is successful).

iOS 11.2 requires XCode 9.2 to build and run. And AppCode 2017.3 does not support XCode 9.2 right now.


Yep, and the log message is so vague and misleading. Just "build failed in x ms"!

I cannot even build using iOS 10 or 11.0. I don't understand why I have to revert back to Xcode 9.1 to do that.


Thanks, Tatiana for the fast response. I appreciate it.

Well, as I am creating the issue, I read the build log and found that the scheme <scheme name> is not found. I added a new scheme and it ran! without any issues.

I, however, added the issue on YouTracker as the issue is still not clear. Here is a link to it:


Please sign in to leave a comment.