I lost many of my settings after upgrade

I upgraded from 2017.2.4 to current version built on 28th of November by downloading patch.

1. It changed my skin and remove custom toolbar. I used some built-in white layout and now it reverted to classic black. I also had rearanged my toolbar menu. I added some stuff for task management and created new icons form them. Now it's lost. I removed some debug icons from toolbar and I can see them again.

2. I lost ssh remote run plugin. I lost my ssh external tools and sftp server credentials.

3. PlantUML is again enabled, but I turned it off.

4. Database tools and SQL plugin was disabled and I lost all included database sources for each project.

5. When I open new task from JIRA issue tracker I can't no more select "update status" becase there is no status on list (list is empty)

All in all: can I import / copy all my settings from 2017.2 folder?

 

 

6 comments
Comment actions Permalink

Hi there,

Settings were transferred nicely here (2017.2.4 to 2017.3; full installer; Windows 10). I suggest doing the same approach: try removing 2017.3 installation and use full installation package -- IMO in general it's more reliable this way (regardless of OS used).

 

For the actual settings -- what you can do is:

  1. Delete current settings for 2017.3 (while IDE is closed, of course) -- Windows/Linux -- one folder; Mac OS -- 4 different folders (see Directories used by the IDE to store settings, caches, plugins and logs )
  2. On next IDE launch it will ask what to do with settings -- just choose to import from previous version

Alternatively -- use "File | Export Settings" in 2017.2.4 (if you still have it installed) and then "File | Import Settings" in 2017.3 . Possible downside -- sometimes (rarely though -- depends on actual IDE version) not all settings may be transferred. In general I recommend first method.

 

Obviously, it's all about IDE-wide settings. Project-specific settings are stored in .idea subfolder of each project root.

3
Comment actions Permalink

First method worked very well. I tried before to use export / import settings but it doesn't work with all settings even with the same version of PHPStorm.

I still have got problem with my point no 5, but it's another case. Thank you for help.

0
Comment actions Permalink

>I still have got problem with my point no 5, but it's another case.

Maybe it's project-specific.

Try this then:

  • Backup your project settings (.idea subfolder) -- while project is closed in IDE, of course
  • Delete that .idea folder
  • Use "Open" or "Open Directory" and point to the project root -- IDE will create fresh project from those files
  • Configure as needed (at least the area where it did not worked before -- Version Control)

If nothing -- you may restore old settings from backup. If works -- re-configure the rest (hint: most of the config files can be copied back from backup copy)

0
Comment actions Permalink

I have just checked this following all your steps. It didn't help. However it works on my 2017.2 version using the same project settings. I'll create issue on YT.

0
Comment actions Permalink

Is it possible to save setting once and for all? Would be great to have an account, where all my settings would be synced.

0
Comment actions Permalink

Does the "Sync settings with JetBrains account" feature work for you?

(https://www.jetbrains.com/help/idea/sharing-your-ide-settings.html)

0

Please sign in to leave a comment.