Flow service doesn't start

I followed the instructions here: https://blog.jetbrains.com/webstorm/2016/11/using-flow-in-webstorm/

And what I'm seeing is "Starting Flow Service" with a spinner that never stops. Eventually it fails with a timeout.

In the command line I run `npm run flow` and it works as expected.

This is the path to flow bin that I'm using: "my/project/node_modules/flow-bin/vendor/flow"

 

Using WebStore 2017.3 and IDEA 2017.3

13 comments

What version of flow-bin do you use? do you have any other Flow services running (in terminal/other IDE)? Try choosing flow package rather than the executable (my/project/node_modules/flow-bin) - does it work?

0

i encountered with same problem. is there any progress ?

1

I found the problem: https://youtrack.jetbrains.com/issue/WEB-30020

Flow 0.60 broke IDE support. Just a few hours ago Flow 0.61 was released with an apparent fix. I'm going to try that soon.

In the meanwhile installing flow-bin@0.59 works.

0

I've tried flow-bin@0.61. Still having this problem.

2

flow-bin@0.66 still not starting flow services as described in topic

1

There is no error shown, at least it doesn't pop anywhere. My problem is when I update the version from 0.59.0 to 0.66.0 and try to `Restart all Flow servers`. It won't start and show `No servers started` on the flow tab. There was another message trying to `show all messages` but I don't recall it since i'm using 0.59.0 now, i don't want to change it to see it either

0

is anything shown in Console tab of Flow tool window?

0

Ran into the same issue; Here's how I unblocked myself when working with react and react-native:

1) update the .flowconfig to use the most recent version of flow: 

[version]
^0.66.0

2) start the flow server from the terminal itself: 

$ flow start

Back in WebStorm, under the Flow tab, I was able to hit the 'Show all errors' button and got flow showing me errors that it detected.

Good luck!

0

I tried what Yeo Ivan say with no luck. When i run `flow start` console says: `Wrong version of Flow. The config specifies version 0.66.0 but this is version 0.59.0`

I did update the .flowconfig and the Flow console says "Services is not started". I also checked the `node_modules` folders and 0.66.0 was there, no 0.59.0

0

Please sign in to leave a comment.