How to update skeletons remote interpreter

Answered

I have a few remote interpreters set up. If I update or install a package on these remote interpreter, pycharm fails to notice, so I will have all kinds of (wrong) warnings in the editor.

Is there a button like "update skeleton" to make pycharm update the skeletons for a particular interpreter, or do I have to remove that interpreter and then add it again?

 

I am using Pycharm 2017.3 Professional Edition on OSX High Sierra

 

Thank you!

9 comments
Comment actions Permalink

Are you guys planning to make it easier to do that in PyCharm?

I run into this situation pretty frequently (add pip packages in the docker image, which runs my "remote interpreter") and it's a pain to follow the above procedure every time?

Exposing this as an Action would be absolutely amazing. 

Thanks for your time & attention!

 

5
Comment actions Permalink

Maybe the fact that it's a paid feature and only users who paid for the software would report it should add some weight? It's especially annoying in Intellij since it doesn't seem to be possible without both tricking Intellij into thinking it needs to update the interpreter, then invalidating the caches.

1
Comment actions Permalink

Hi guys,

Looks like this unobvious feature is completely broken in 2020.1 (Mac OS Catalina). 

1
Comment actions Permalink

Hi Apolino! The button exists but it's not so easy to find, you need to go to Settings | Project ... | Interpreter | Gear button | More | Interpreter Paths | Reload, here is a screenshot:

0
Comment actions Permalink

Ah, perfect! Thank you very much! :D

0
Comment actions Permalink

Is there any way to do this on IntelliJ with the Python Plugin?

0
Comment actions Permalink

Hi nombreinvicto

There is no such button in IntelliJ IDEA with Python plugin. You could use File | Invalidate Caches /Restart... , but it's not that convenient since it will force re-indexing.

0
Comment actions Permalink

Having the same issue as well, because I am pushing my code via `Deployment` and than I am executing a `pip install` from that pushed data. Problem: The changes are not recognized in the remote package, because the data is in cached in `Pycharm` within `.cache`. So now... Everytime when I install or upgrade a python package within the python3 interpreter, I need to **Settings | Project ... | Interpreter | Gear button | More | Interpreter Paths | Reload** or **File | Invalidate Caches /Restart** (which takes 15-30 minutes)?

0
Comment actions Permalink

@Paul Milovanov

We don't have plans since it's not a frequently reported issue, but Please feel free to submit a corresponding feature request to our issue tracker using the link https://youtrack.jetbrains.com/issues/PY and let us know if you need any help.

-6

Please sign in to leave a comment.