Webstorm 2017.3 Hanging after upgrade

Just upgraded today to latest Webstorm and have been unable to use it ever since. The app starts and starts to index but then it freezes and has to be Force Quit (on a Mac). Tried cleaning out Cache/Preferences but no luck. I thought for a minute that disabling the Ignore plugin might have done it but I was wrong. Still freezing.

26 comments

Hi there,

Anything interesting in idea.log (Help | Show Log in XX) ?

 

>Tried cleaning out Cache/Preferences but no luck.

What preferences files/folders have you removed?

Directories used by the IDE to store settings, caches, plugins and logs

0

Same here! What can I do to fix? Clean some cache files? Where?

0

When I restarted it was clear that I hadn't properly cleaned out my preferences. Removing preferences/cache and the app and then reinstalling seems to solve the problem for me.

Preferences were `~/Library/Preferences/Webstorm2017.3` for me on OSX 10.13.1

 

Possibly relevant was that this time after install I got the "some of your plugins are not compatible" and then did an upgrade of the plugins which I did not get the first time.

0

>Possibly relevant was that this time after install I got the "some of your plugins are not compatible" and then did an upgrade of the plugins which I did not get the first time.

Quite possibly -- I've seen reports here on forum where rather weird errors were shown with outdated plugins running (PHP-related plugins in those cases though). Not sure about freezing because of that.

>Preferences were ...

For me.. if I'm going to do such radical step as starting from scratch by deleting all preferences/settings ... I would delete ALL stuff (Linux/Windows -- all in one folder; Mac OS -- 4 different folders (preferences, plugins, indexes/caches, and logs))

 

In any case: you've made IDE working again .. which is the main point.

0

What did it for me was to uninstall Webstorm, remove the ~/Library/Caches/WebStorm2017.3 folder and reinstall. It's working normally now.

0

To be clear, I didn't need to "start from scratch". I had just upgraded to 3 from 2, so I just had to "migrate from previous version" which is what I had just done before the problems started. So I was back exactly where I was before. No reconfiguration necessary. I did not need to delete the configuration from previous versions.

0

>To be clear, I didn't need to "start from scratch"

I see. Thanks for clarification.

0

It didn't solve it for me after all.

The IDE keeps hanging and I cannot edit any files.

Thread dumps here.

It throws after rebuilding the file indexes:

2017-12-03 12:17:20,648 [ 25926] INFO - il.indexing.FileBasedIndexImpl - Rebuild requested for index Stubs
java.lang.Throwable: and some indices were dropped
at com.intellij.psi.stubs.StubIndexImpl$StubIndexInitialization.finish(StubIndexImpl.java:668)
at com.intellij.psi.stubs.StubIndexImpl$StubIndexInitialization.finish(StubIndexImpl.java:633)
at com.intellij.util.indexing.IndexInfrastructure$DataInitialization.call(IndexInfrastructure.java:166)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at com.intellij.util.concurrency.BoundedTaskExecutor$2.run(BoundedTaskExecutor.java:212)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)

Thank you.

0

Are there any specific steps that lead to the issue? Dumps show that most delays are related to importing Meteor packages as library action

0

Hi Elena, nope, that's all I can say. Do you have any workaround I can use? Not fun to develop with vim...

0

Hi Elena, what steps should I take to reinstall Webstorm from scratch (cleaning all the caches, preferences, etc) ?

0

Just here to say that this issue has reappeared since I temporarily (apparently) fixed it a couple of days ago by removing preferences. Was working fine for a couple of days, but freezes on "indexing". And when it freezes it's a hard freeze with beach ball that can only be force quit out of.

0

So I have deleted all preferences and not doing "previous version". When I open a pure React project it seems fine, but when I open a Meteor project, including a blank one just created with `meteor create` it freezes every time.

0

Please try disabling Automatically import Meteor packages as external library  in Preferences | Languages & Frameworks | JavaScript | Meteor - does it make things any better?

0

Elena, that seems to have solved it, but now I've lost intellisense for meteor packages. Is there a workaround for this? Cheers

0

You can try downloading packages manually by clicking Import packages as library link in .meteor/packages file (you need to open it in the editor)

0

Yup, that worked, thanks. But if I choose "import from npm" in that "import packages as library" dialog, the UI hangs (as previously). If I only check client and server, works fine.

0

I am experiencing the same issue. It seems like disabling meteor plugin solves it for now. I am wondering if the fix will be available soon?

0

We can't see any evident issues here. "import from npm" does indeed take noticeable time (there is a huge number of packages to be imported and reindexed), but the IDE doesn't hang - once import is completed, it works fine

0

You're right Elena. Did it just now (for npm and cordova libraries). It did take a while but it worked. Cheers.

0

Same problem.  I'm using meteor.  this turning off the meteor plugin helped for a minute... but now whenever i install something via npm the entire webstorm environment hangs.  I'm not sure what the issue is, i've tried everything.  this is now really killing productivity.  

0

I have the same problem. I've tried to uninstall app and clear ~/Library/Caches/WebStorm2017.3 - nothing helps me. Webstorm is freezing after choose the project or create new one.

For me help rollback to 2017.2.5

1

please provide thread dumps then.

And would you be so kind to create a separate thread for your issue? Handling different problems from different users in a single thread is a pain; usually I prefer not to comment on such long threads

0

Please sign in to leave a comment.