ESLINT fix all problems doesn't work

Running Webstorm 2017.2.4

I configured a shortcut for 'ESLINT fix all problems'

Unfortunately it doesn't do anything.

Is there a bug regarding this feature in the latest webstorm version ?

 

 

In the bellow example, hitting CMD + I should fix the indentation...

 

8 comments

We are not aware of such regression, shortcut works for me. Can you apply the fix via Alt+Enter, ESLint:Fix current file action? Also, is the issue specific to JSX files? Did you try invalidating caches?

0

Thanks for your reply. The fix doesn't work either via Alt+EnterESLint:Fix 

I encouter the problem on js and jsx files

0

Did you try invalidating caches (File | Invalidate caches, Invalidate and restart)? If this doesn't help, please share a sample project I can use to recreate the issue

1

 Here is a repo with a project that has the issue

https://github.com/leoparis89/lintest

I shoud be able to clean the file by selecting 'fix current file'

Yes I invalidated the cache.

I cleared library/preferences and reinstalled webstorm.

I am runnning OSX 10.12.6 (16G1036) and Webstorm 2017.3.

I can't believe no one has had this issue ? 

 

 

0

I ran several tests:

Tslint autofixing from the IDE works on my OSX machine. (tried it on an angular-cli project)

EsLint autofix from IDE does work when I open my projects on an ubuntu Machine (using same webstorm version).

There seems to be an issue with Eslint fixing from the IDE on  OSX 10.12.6. 

0

Auto-fixing works fine for me using your project, both with shortcut and the menu action... Does fixing work for you when running ESLint in terminal?

Please can you recreate the issue and provide idea.log (https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files) from your OSX machine? Please don't paste it here, put it on some file server

0

Thanks for your help.

I found where the bug comes from :

On OSX (didn't try on linux), if your work directory path contains a directory with a space in it, the built in EsLint webstorm autofix fails silently.

Try reproducing the bug.

 

0

Please sign in to leave a comment.