My Ctrl + Alt + A has stopped working and there is no Git > Add... option in Keymap!

Howdy

 

I noticed today that my Ctrl + Alt + A doesn't work anymore. It is mapped (not sure whether it was default or me who mapped it) to Git > Add. When I try to go into Settings > Keymap I can't find the related command either - there is no Add... in Main Menu > VCS > Git or Version Control Systems > Git. I tried switching between and older and newer version but both exhibit the same issue.

 

Any help would be much appreciated.

Thanks,

Claude

 

13 comments

Missing Git Add in keymap preferences is a known issue, see https://youtrack.jetbrains.com/issue/IDEA-98689. But Ctrl + Alt + A shortcut still works, and the action is available in Main Menu > VCS > Git:

Are other Git actions available in VCS > Git menu? Please provide a screenshot of this menu plus your idea.log (please don't paste its content here, put it to some file server)

0

Hi there

 

Thanks for the reply. The menu options are in fact there and say that the shortcut key is Ctrl + Alt + A. But the binding does not work. So I wanted to change the binding and see if it was being overridden by another app in memory or the OS, but I haven't installed anything new so I'm stumped at the moment.

 

My idea.log can be found at https://file.town/download/04dbwy9g2s6ikhbk5liams0rx

Thanks,

Claude

0

You can't change the binding (https://youtrack.jetbrains.com/issue/IDEA-98689)

What is your system keyboard layout?

0

Yes I realise that if the option to rebind isn't available in the setting, one wouldn't be able to rebind, that's how I realised that Add... was missing.

My system keyboard layout on Windows 10 here is US (Qwerty).

0

This must be a keymap conflict then... BTW, did you check if you can add files using menu actions (i.e. when not using shortcut)?

0

Yes I can add files via the menus. Yeah I'll have to hunt for the conflict :(

0

Update:

I tried https://superuser.com/questions/11308/how-can-i-determine-which-process-owns-a-hotkey-in-windows but the app keeps crashing at step 9.

I then tried the shortcut in another application and it doesn't work there either so it seems the combo is broken (seems unlikely) or the combo is being highjacked. I will try a different keyboard later just for grins.

OK so re https://youtrack.jetbrains.com/issue/IDEA-98689 I remapped VSC > Add file to a new shortcut key and that works for Git as stated, but it's really bugging me what is highjacking Ctrl + Alt + A!!! Not to mention I've gotten used to Ctrl + Alt + A :(

 

0

I also have this issue. What I noticed was that Ctrl + Alt + A does not seem to work on anything. I tested some JS libraries to see if they could pick it up and they couldn't.

0

Confirmed - not the keyboard. I tried to map Ctrl + Alt + A to a shortcut in Sublime Text and it doesn't work there either.. So it seems that it isn't a WS specific thing, seems to be highjacked by something - it is totally bizarre! :(

0

@Claude Muller

IDE (WebStorm/PhpStorm/etc) has a special button next to the search field on "Settings | Keymap" -- it allows to find actions by assigned shortcut. This also means that you can use it to see if IDE recognizes such shortcut (e.g. if it's not intercepted by some another app/OS).

So ... since you are on Windows:

  1. Start closing currently running apps one by one (close one -- see if shortcut works again) -- extremely likely that it will be one of the auto-starting apps (e.g. some Instant Messaging/chat apps)
  2. If nothing -- check graphic card driver options -- they also may use system-wide shortcuts for their needs (e.g. rotate screen etc)

Basically -- check everything in notification/system tray.

You may also try and temporarily disable all auto-start programs (can be done from Task Manager for example).

 

1

Thanks Andriy. I hadn't had a chance to investigate to that degree yet as deadlines loom, but this afternoon all of a sudden it started working again! It's obviously something on my system.

 

Thanks :)

0

I had the same problem in Windows.

I had "Keep Pass 2" progam open, closed it and "Ctrl-Alt-A" have been functional in Webstorm since then!

And here is the proof:

https://keepass.info/help/base/autotype.html

1

Oooooh, crap, thanks guys to discuss this problem!!! I had the same issue, after update to Win 10, my Ctrl+Alt+A stop working in Intelij IDE. It was so annoying, because I used to this shortcut, and very often I just didn't commit some files only because I didn't add them to commit(because shortcut didn't work), and pushed my code without changes.

It happened because stupid KeePass have Ctrl + Alt + A shortcut binding for Global auto-type action. I have removed it from here and it started working in Intelij IDE

1

Please sign in to leave a comment.