Format should not optimize imports

I don't know with which version it started, but for a while now the format action also optimizes imports and since the latter is very unreliable and often leads to compile errors I have to format the code manually. It would be nice (and should be an easy fix) if you could seperate these actions again, so that a format really only formats the code according to configured code style and leaves the imports as they are

1 comment
Comment actions Permalink

Ok, now I found out what went wrong: I have to bring up the Reformat Code Dialog (Ctrl,Alt,Shift,L) and uncheck the Optimize Imports option

1

Please sign in to leave a comment.