Disable Scientific mode in PyCharm

Answered

Hi,

 

How do I turn off Scientific mode permanently in Pycharm IDE?

7 comments
Comment actions Permalink

Hi Sdworman! With two actions:

  1. Disable View | Scientific Mode
  2. Disable Settings | Tools | Python Scientific | Show plots in tool window

Has it helped?

1
Comment actions Permalink

Hi Pavel,

I could not get either to work.  I still see a Special Variables window in the bottom right corner, even after I unselect Scientific mode.  How do I get rid of the Special Variables window?  

1
Comment actions Permalink

Sdworman, oh, this sub window can be disabled with Settings | Build, Execution, Deployment | Show console variables by default.

0
Comment actions Permalink

A follow-up question: I understand how to disable "Show plots in tool window" within a project, but how can I configure PyCharm to disable this option by default for new projects? If I open preferences with no project open, "Python Scientific" is not available under "Tools". 

5
Comment actions Permalink

Hans, close the project and `rm .idea/*`,

then reopen the project

-2
Comment actions Permalink

Curently it's not possible. We have related request on YouTrack: https://youtrack.jetbrains.com/issue/PY-27324, but you are welcome to open separate one for default option.

-6
Comment actions Permalink

Hello all

a quick fix to prevent the sciview by default is to add a PySciProjectComponent to the file at C:\Users\<YOUR USER>\AppData\Roaming\JetBrains\PyCharm2021.2\options\project.default.xml inside <default project>

<component name="PySciProjectComponent">
<option name="PY_SCI_VIEW_SUGGESTED" value="false" />
<option name="PY_MATPLOTLIB_IN_TOOLWINDOW" value="false"/>
</component>

 

0

Please sign in to leave a comment.