PhpStorm keeps indexing over and over again

Answered

PhpStorm keeps reindexing over and over again.

Tried to restart the app, but wouldn't solve the problem.

40 comments
Comment actions Permalink

I'm still having this same problem. The darned thing keeps indexing, and it's starting to drive me a little nuts. I updated to 2020.1.2 this morning, but it's still doing it. I'm in the middle of typing some code, and I don't see it on the screen. Then I look down and the thing is indexing again. Why? I've done the invalidate caches, deleted the .ideas directory.... I'm on MacOS 10.15.4. 

0
Comment actions Permalink

remy.courteaud How/where can directories and files be excluded?

0
Comment actions Permalink

Pweil2 Maybe try to mark files or directories as excluded that don't need to be analyzed (like logs or builds).

On mac => Right click => mark directory as => excluded

Or through settings => Settings => Directories

0
Comment actions Permalink

Rémy

Thanks, I'm giving this a try. But some of my exclusions are just guesses. Does JetBrains have a general recommendation for excluding files in certain kinds of projects (mine is a Laravel/Vue app). I've been using PHPStorm for several years, and have never come across this problem before.

0
Comment actions Permalink

Pweil2 When I had the indexation issue (long time ago) the indexation wouldn't stop for a second. I guess if that's your case to there might be something else going on... Also I guess it depends on your computers CPU and RAM. In my projects (Symfony/ Webpack) I exclude all vendor directories, logs directories, and build directories (JS that constantly gets recompiled during developpement) because they will cause a lot of reindexation and I don't need IDE analysis (syntax and stuff) on these.

0
Comment actions Permalink

Cardinal solution.
Resetting the cache didn't help me either.
But removing the following storm directories helped:

  • BEFORE DELETING, MAKE A BACKUP OF DIRECTORIES DATA!
  • If you keep your projects there, do not delete project files!
  • After removing, I lost some PHPStorm settings, but for that I can continue working on the project.
  • C:\Users\{UserName}\PHPStorm ...
  • C:\Users\{UserName}\AppData\Local\JetBrains
  • Be careful
0
Comment actions Permalink

This is incredibly surprising that the indexing issues have been persisted for 6years. I feel sad that I recommended buying this product in my company and now everyone in my team is just frustrated with this indexing issue despite having the latest version installed. All I see everywhere is "Invalidate Cache and Restart" but it does not work. Some solutions say Exclude the directories but still indexing happens every time. I have to keep the indexing program running overnight so that I can use the IDE next morning.

Sad part is if you don't index then Search doesn't work either.

0
Comment actions Permalink

There are no perfect products. PHPStorm the best I've seen and not expensive.
And the problem can be solved, described in a previous comment

0
Comment actions Permalink

That's odd we use PhpStorm in my company on many different computers with no issues.

0
Comment actions Permalink

Garad U, please contact support whenever you have issues, we can't fix a problem we are not aware of. Submitting your logs (Help | Collect Logs and Diagnostic Data) via Help | Contact Support is a good way to start. Thank you.

0

Please sign in to leave a comment.