Empty Test Logs With Rspec Runner

RM 2017.3 (Build 173.3727.132)

Ruby 2.4.2p198

Rails 5.1.4

rspec-rails 3.7.2

rspec 3.7.0

I am using the Rspec run configuration and I am not getting any test log output when I run tests from the run configuration.. When I run `rails rspec` from command line, I do get test log output.

Here is the command that is running:

/Users/markfraser/.rbenv/versions/2.4.2/bin/ruby -e $stdout.sync=true;$stderr.sync=true;load($0=ARGV.shift) /Users/markfraser/.rbenv/versions/2.4.2/bin/rspec _3.7.0_ /Users/markfraser/development/flinkapps/fanlink/spec --require teamcity/spec/runner/formatter/teamcity/formatter --format Spec::Runner::Formatter::TeamcityFormatter --pattern **/*_spec.rb --fail-fast


If I run this configuration:

I get logging but I haven't been able to get the --fail-fast parameter working with this configuration.


Can someone please clue me in on how to get the logging to work properly with the Rspec runner?



To clarify. The actual test.log file is not getting updated. This isn't about whether I can see the output in Ruby Mine.


Ok..I got a clue when I noticed my dev db was being overwritten every time I ran tests.

I've not usually had to specifically set RAILS_ENV=test when adding a new test config. Seems like hitting "+" under the built-in RSpec tab should do that automatically (or at least the test runner should take care of it).



Hello Mark,

sorry for the delay. Did you run the rspec tests in question from the project tree? Does it happen to all your projects? In addition, would it be possible to check how it goes in RubyMine 2017.3.2?


Please sign in to leave a comment.