Pycharm error- Could not find main class com/intellij/idea/main

Recently I installed pycharm on my windows 7 32-bit pc(2gb ram). After successfull installation, it doesn't open and shows this error "could not find main class com/intellij/idea/main".
I tired running pycharm.exe file and it shows the same error.. I have python already installed in my pc just need an IDE..
What's the problem? Is it because my pc is 32-bit? (I selected 32-bit only while installing but it created a pycharm64.exe file in C: /Program files/jetbrains).)
Any help would be appreciated.
Thanks.

15 comments

Hello.

Please try to uninstall PyCharm, download 2017.3 and install it again. Choose "32-bit launcher". If it will not help, please attach log file from ``%USERPROFILE%\.PyCharm2017.3\system\log``. You can also create issue in https://youtrack.jetbrains.com with this log file.

0

I'm also having a same issue.  Installed PyCharm on the following address and attempted to open "32-bit launcher" but failed. 

\PyCharm Community Edition 2017.3.2

My computer is windows 7 32-bit. Already installed version 2017.3.1 but failed.

Thanks in advance.

0

I could not find the log file you mentioned above.  "log file from `%USERPROFILE%\.PyCharm2017.3\system\log``.". Here is the folders I can see. 

Which log file are you aiming at?

0

I assume this is PyCharm installation folder. Do you see ".PyCharm2017.3" folder in your profile folder like "c:\users\<your_name>"? It may be hidden, so you may need to enable "show hidden folders" option in explorer.

 

0

I could only find the following folders Ilya suggested. There is no ".PyCharm2017.3" folder.

0

I could finally open PyCharm with installing Java. Thanks for your comments anyway.

1

Hey.. Which version of Java did you install.. It would be very helpful if you Can keep the download link here.
Thanks

0

I was receiving error as "could not find main class com/intellij/idea/main" when trying to launch JetBrains Pycharm tool.

Observation :- While checking this issue I tried below steps

 1. Uninstalled Pycharm tool and re-installed same using MSI installer.

2. Checked Java( JDK) version which was 1.6 and also JRE  version as 1.6 on my computer.

3. Downloaded latest version of Java( JDK & JRE) -1.8 and installed same to different location in C drive.

4. Launched JetBrains Pycharm tool again and now it is working fine as expected.

 

Happy to help !

Hopefully this would work for people who are facing similar kind of issues. Thanks and let me know if you have any questions.

0

Thank you, Jawaharkawade.

By the way:

1) Intellij-based products (including PyCharm)  use NSIS, not MSI AFAIK

2) JRE 1.8 is required (1.6 is not supported anymore)

3) It is highly recommended to use JetBrains version of JRE bundled with PyCharm. Many UI issues are fixed there)

0

Hello there,

I just installed Phpstorm 2018.2.4 on my Windows XP but faced the same problem while I do not have Python or Pycharm on my laptop. 

BTW, as mentioned earlier error is as follow: 

error launching PhpStorm
could not find main class com/intellij/idea/Main

Thanks!

0

Hello.

Windows XP is not supported. Please use Windows 7, 8 or 10.

 

0

Hi.

Thank you for your response!

Is it possible to use an older version of Phpstorm which supports Windows XP?

Thanks,

Tom

0

You can try installing one of older versions listed here, e.g. 2016.2. Unfortunately I can't find the exact version when Windows XP support ended.

0

Hi Dmitry,

I did find an older version and could install it on my laptop. The PhpStorm-2016.3.4 version worked for me.

Thank you so much for your help.

Best,

Tom 

0

Please sign in to leave a comment.