Update ssh key to use new passphrase

Answered

I've changed my SSH keys on my various computers (a thing I do yearly). The new SSH keys have passphrases that I also change yearly.

Having changed the keys, manual git pulling/pushing works as expected. However, with PHPStorm, when I attempt to push or pull i get:

`Invalid passphrase for the key ... (3 attempts)`

 

I have *hundreds* of passwords stored in the database for auto ftp/pushing/mysql logins.

How do I simply get a prompt for this one password to change?

 

  • Computers in use: W10, W8.
  • Using github.

 

Thanks

Rick

6 comments
Comment actions Permalink

Does switching to the native SSH executable help?
Settings | Version Control | Git

0
Comment actions Permalink

No, although it's a slightly different error:

  • Fetch failed : Could not read from remote repository

 

 

0
Comment actions Permalink

That seems to be a issue on our side: https://youtrack.jetbrains.com/issue/IDEA-184450. Please check if a workaround suggested in comments helps.

0
Comment actions Permalink

Native mode does not allow handling any prompts at all. With native mode, one needs to use a key without a passphrase, or load it to ssh-agent first.

The Built-in SSH mode should prompt for the passphrase, and it is a bug it does not.

I see you opened an issue on YouTrack, please follow for updates.

https://youtrack.jetbrains.com/issue/IDEA-184450

0
Comment actions Permalink

I can confirm that the workaround is successful. From the looks of the ticket I made has been accepted and should be fixed at some point. To be clear of workaround:

  • Download KeePass (note you dont have to install - can run without OS install, like PuTTY)
  • Open KeePass file (location is shown in the settings/passwords section)
  • Delete the entry for your ssh key
  • Save this to the DB

This then calls the a functioning dialogue box for the key.

Thanks all.

0
Comment actions Permalink

A solution that worked for me:  under Settings > Appearance & Behavior > System Settings > Passwords, I switched from "In native keychain" to "in keypass".  Then I was prompted for my rsa key's password upon my next `git pull`.

 

Admittedly, unlike the OP, I only had a single password to worry about.  For those with several passwords, or who want to continue using their native keychain, this may be a bad idea.

1

Please sign in to leave a comment.