Bundler is not working with remote sdk in Linux and rbenv

I  installed bundler according to the event log[ RubyMine Gem Manager: RubyMine has detected that some of the gems required for 'XXX' are not installed. Install], 

but this error was not fix. After this install action, same event log was displayed.

And other conditions were below, 

1) Tools > Bundler > Install Bundler is only displayed, and other commands(Update and Install etc) is not displayed).

2) Gem list of this ruby sdk is not shown in the [Ruby SDK and Gems] section.

3) Gem environment:

 RUBYGEMS VERSION: 2.5.1
RUBY VERSION: 2.3.1 (2016-04-26 patchlevel 112) [x86_64-linux]
INSTALLATION DIRECTORY: /usr/local/rbenv/versions/2.3.1/lib/ruby/gems/2.3.0
USER INSTALLATION DIRECTORY: /root/.gem/ruby/2.3.0
RUBY EXECUTABLE: /usr/local/rbenv/versions/2.3.1/bin/ruby
EXECUTABLE DIRECTORY: /usr/local/rbenv/versions/2.3.1/bin
SPEC CACHE DIRECTORY: /root/.gem/specs
SYSTEM CONFIGURATION DIRECTORY: /usr/local/rbenv/versions/2.3.1/etc
RUBYGEMS PLATFORMS:
ruby
x86_64-linux
GEM PATHS:
/usr/local/rbenv/versions/2.3.1/lib/ruby/gems/2.3.0
/root/.gem/ruby/2.3.0
GEM CONFIGURATION:
:update_sources => true
:verbose => true
:backtrace => false
:bulk_threshold => 1000
:sources => ["https://rubygems.org/", "http://production.cf.rubygems.org/"]
REMOTE SOURCES:
https://rubygems.org/
http://production.cf.rubygems.org/
SHELL PATH:
/usr/local/rbenv/versions/2.3.1/bin
/root/.gem/ruby/2.3.0/bin
/usr/local/rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/bin
/usr/local/rbenv/shims
/usr/local/rbenv/bin
/usr/local/sbin
/usr/local/bin
/sbin
/bin
/usr/sbin
/usr/bin
----------------------
IDE: RubyMine 2017.3.1, build #RM-173.3942.35
OS: Mac OS X 10.13.2[x86_64]
Java: 1.8.0_152-release-1024-b8
RubyMine SDK Environment:
Sdk: Remote: ruby-2.3.1-p112 (1)
Sdk Version: ver.2.3.1p112 ( revision 54768) p112
Ruby Interpreter: sftp://root@210.129.17.XXX:22/usr/local/rbenv/versions/2.3.1/bin/ruby
RVM Sdk: no
RVM Home: [n/a]
Sdk Language Level: 2.3
Sdk Load Path:
/Applications/RubyMine.app/Contents/rubystubs23
Sdk Gem paths:
~/Library/Caches/RubyMine2017.3/ruby_stubs/-1345687432/890086132/gems
~/Library/Caches/RubyMine2017.3/ruby_stubs/-1345687432/1610074352/gems
~/Library/Caches/RubyMine2017.3/ruby_stubs/-1345687432/1610074352/bundler/gems
~/Library/Caches/RubyMine2017.3/ruby_stubs/-1345687432/890086132/bundler/gems
Gems used for 'App2':
rb-inotify (bundled(0.9.10))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/rb-inotify-0.9.10
metric_fu-Saikuro (bundled(1.1.3))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/metric_fu-Saikuro-1.1.3
execjs (bundled(2.7.0))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/execjs-2.7.0
rubyzip (bundled(1.2.1))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/rubyzip-1.2.1
i18n (bundled(0.9.1))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/i18n-0.9.1
mini_portile (bundled(0.5.3))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/mini_portile-0.5.3
builder (bundled(3.2.3))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/builder-3.2.3
rb-readline (bundled(0.4.2))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/rb-readline-0.4.2
thread_safe (bundled(0.3.6))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/thread_safe-0.3.6
ffi (bundled(1.9.18))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/ffi-1.9.18
erubi (bundled(1.7.0))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/erubi-1.7.0
minitest (bundled(5.10.3))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/minitest-5.10.3
commander (bundled(4.4.3))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/commander-4.4.3
whenever (bundled(0.10.0))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/whenever-0.10.0
ice_nine (bundled(0.11.2))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/ice_nine-0.11.2
thor (bundled(0.20.0))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/thor-0.20.0
descendants_tracker (bundled(0.0.4))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/descendants_tracker-0.0.4
coffee-script-source (bundled(1.12.2))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/coffee-script-source-1.12.2
will_paginate (bundled(3.1.6))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/will_paginate-3.1.6
diff-lcs (bundled(1.3))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/diff-lcs-1.3
kgio (bundled(2.11.1))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/kgio-2.11.1
rspec-mocks (bundled(3.5.0))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/rspec-mocks-3.5.0
enumerable-lazy (bundled(0.0.2))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/enumerable-lazy-0.0.2
database_cleaner (bundled(1.6.2))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/database_cleaner-1.6.2
uglifier (bundled(4.0.2))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/uglifier-4.0.2
docile (bundled(1.1.5))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/docile-1.1.5
concurrent-ruby (bundled(1.0.5))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/concurrent-ruby-1.0.5
sprockets (bundled(3.7.1))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/sprockets-3.7.1
ruby-debug-ide (bundled(0.6.0))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/ruby-debug-ide-0.6.0
ruby_dep (bundled(1.5.0))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/ruby_dep-1.5.0
ref (bundled(2.0.0))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/ref-2.0.0
chronic (bundled(0.10.2))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/chronic-0.10.2
json (bundled(1.8.6))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/json-1.8.6
msgpack (bundled(1.2.0))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/msgpack-1.2.0
coffee-script (bundled(2.4.1))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/coffee-script-2.4.1
debase (bundled(0.2.1))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/debase-0.2.1
rack-test (bundled(0.8.2))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/rack-test-0.8.2
libv8 (bundled(3.16.14.19))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/libv8-3.16.14.19-x86_64-darwin-15
turbolinks-source (bundled(5.0.3))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/turbolinks-source-5.0.3
childprocess (bundled(0.8.0))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/childprocess-0.8.0
mustermann19 (bundled(0.4.4))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/mustermann19-0.4.4
public_suffix (bundled(3.0.1))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/public_suffix-3.0.1
multi_xml (bundled(0.6.0))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/multi_xml-0.6.0
chunky_png (bundled(1.3.8))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/chunky_png-1.3.8
crass (bundled(1.0.3))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/crass-1.0.3
rspec-core (bundled(3.5.4))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/rspec-core-3.5.4
addressable (bundled(2.5.2))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/addressable-2.5.2
simplecov-html (bundled(0.10.2))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/simplecov-html-0.10.2
arel (bundled(8.0.0))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/arel-8.0.0
highline (bundled(1.7.10))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/highline-1.7.10
equalizer (bundled(0.0.11))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/equalizer-0.0.11
psd-enginedata (bundled(1.1.1))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/psd-enginedata-1.1.1
rake (bundled(11.1.2))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/rake-11.1.2
tilt (bundled(2.0.8))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/tilt-2.0.8
hashie (bundled(3.5.6))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/hashie-3.5.6
tzinfo (bundled(1.2.4))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/tzinfo-1.2.4
ruby-ole (bundled(1.2.12.1))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/ruby-ole-1.2.12.1
mail (bundled(2.7.0))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/mail-2.7.0
nio4r (bundled(2.1.0))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/nio4r-2.1.0
rb-fsevent (bundled(0.10.2))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/rb-fsevent-0.10.2
rspec-support (bundled(3.5.0))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/rspec-support-3.5.0
rack-proxy (bundled(0.6.3))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/rack-proxy-0.6.3
unicode-display_width (bundled(1.3.0))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/unicode-display_width-1.3.0
rack (bundled(2.0.3))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/rack-2.0.3
debase-ruby_core_source (bundled(0.10.1))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/debase-ruby_core_source-0.10.1
oily_png (bundled(1.2.1))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/oily_png-1.2.1
net-scp (bundled(1.2.1))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/net-scp-1.2.1
grocer (bundled(0.7.1))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/grocer-0.7.1
mini_mime (bundled(1.0.0))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/mini_mime-1.0.0
bcrypt-ruby (bundled(3.1.2))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/bcrypt-ruby-3.1.2
headless (bundled(2.3.1))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/headless-2.3.1
raindrops (bundled(0.19.0))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/raindrops-0.19.0
multi_json (bundled(1.12.2))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/multi_json-1.12.2
rack-accept (bundled(0.4.5))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/rack-accept-0.4.5
websocket-extensions (bundled(0.1.3))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/websocket-extensions-0.1.3
bindata (bundled(2.4.1))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/bindata-2.4.1
websocket-driver (bundled(0.6.5))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/websocket-driver-0.6.5
net-ssh (bundled(4.2.0))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/net-ssh-4.2.0
autoprefixer-rails (bundled(7.2.3))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/autoprefixer-rails-7.2.3
rspec-expectations (bundled(3.5.0))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/rspec-expectations-3.5.0
method_source (bundled(0.9.0))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/method_source-0.9.0
rdoc (bundled(4.3.0))
~/Projects/App2/vendor/bundle/ruby/2.3.0/gems/rdoc-4.3.0

How can I fix it?

Thanks.

 

 

2 comments

It is caused by Rsync in remove server.

By check off [Registry > ide.remote.interpreters.use.rsync],  bundler is installed.

Gem list of this ruby SDK in remote server is shown after that.

0

Thanks for this. I had the same problem and was tearing my hair out!!

JetBrains should really add this to their documentation (or at least tell their support people about it)

0

Please sign in to leave a comment.