Ruby cocoa non zero return code on require osx/cocoa

I'm trying to run ruby cocoa from rubymine on my Mac os high sierra.

the "require  'osx/cocoa' " statement causes the following error:

/usr/bin/ruby -e $stdout.sync=true;$stderr.sync=true;load($0=ARGV.shift) "/Users/mac/cocoa test 2/RC2.rb"
/System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- osx/cocoa (LoadError)
from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /Users/mac/cocoa test 2/RC2.rb:1:in `<top (required)>'
from -e:1:in `load'
from -e:1:in `<main>'

Process finished with exit code 1


Can anyone help?

I'm new on the mac so my knowledge of pertinent directories and paths is very limited...



Chuck Brotman

1 comment

Hello Chuck,

do you manage to run the same code from Terminal? In addition, we have a request regarding MacRuby:


Please sign in to leave a comment.