phpStorm resets PHP language level after restart

Every time i close and reopen the phpStorm IDE the "PHP language level" setting resets from 5.6 to 5.3 in both the actual projects preferences and the default project preferences.

I have not found anything on the internet on this problem. I hope somebody here can help me.

Info:
PhpStorm 2017.3.2
Build #PS-173.4127.29, built on December 22, 2017
JRE: 1.8.0_152-release-1024-b8 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.13.2

7 comments

Same Problem here - Mac OS X 10.13.2

0

Every Time I set it to 7 and apply. It Works and when I restart phpStorm it is set to 5.3 again.



1

@Bernhard Zuern

Try checking the links given first -- the reason and possible solutions are there.

2

Well first comment solved it for me, just edit the php version in your composer.json

1

Yes I can confirm - it solves the problem for me. Thanks a lot !

0

To people experiencing this problem: I would use unchecking the "synchronize with composer.json" solution before changing the version in composer.json, unless you are *absolutely* sure that you will never have to support anything lower, and that none of your dependencies will ever have to use a lower versioned php installation.

The composer.json option has more far reaching consequences (being checked each time you deploy to a different environment or install a new dependency) than changing your phpstorm configuration.

2

Please sign in to leave a comment.