WebStorm debug run another instance of Chrome instead of currently running one

 WebStorm debug run another instance of Chrome instead of currently running one.

When I run, it will run on Chrome that currently running, the one with my settings and plugins (And also Jetbrain IDE Support)
but when i click debug, it will pop up another instance of Chrome, which have none of my settings and plugins, it look like fresh installed Chrome

It start to be like this since I update from WebStorm 2017.1 to 2017.3
How can I fix it?

P.S. sorry for my English, It's not my native language

13 comments
Comment actions Permalink

Since 2017.3, Chrome extension is not used for debugging by default - see https://blog.jetbrains.com/webstorm/2017/10/webstorm-2017-3-eap-173-3415/,. Chrome protocol with --remote-debugging-port option is used instead. Debugging session is started in a new window and using custom profile because it's required to run chrome with --remote-debugging-port argument, and a port for debugging can't be opened after browser is started.

If you like to debug with extension, as before, please enable Update application in Chrome in Preferences | Build, Execution, Deployment | Debugger | Live Edit

See also https://www.jetbrains.com/help/webstorm/2017.3/debugging-javascript-in-chrome.html, Starting a debugging session with your default Chrome profile

1
Comment actions Permalink

Thank you so much :)

0
Comment actions Permalink

I enabled  Update application in Chrome and it still opens a new Chrome window.  What else can it be?

1
Comment actions Permalink

I figured it out.  My VPN Extenion was active.  Once I turned off the VPN all was good.

1
Comment actions Permalink

This might be a different issue. But my phpstorm is opening Chrome without any of my chrome extensions and with me not logged into Google. I thought it might be that phpstorm is opening chrome as root, but the activity monitor shows a second Google Chrome process with my regular user.

PHPStorm 2018.1.1

OSX Sierra.

0
Comment actions Permalink

Thanks.

For me the best solution was to allow PHPStorm to continue to use it's own profile and simply synchronise my settings. I only had to login to google to pull down all my extensions anyway.

I was able to configure PHPStorm to launch Chrome using my main profile, but I couldn't start a debugging session without closing all chrome windows and exiting the application first. Not workable if you already have a bunch of other windows open for other purposes.

0
Comment actions Permalink

>I was able to configure PHPStorm to launch Chrome using my main profile, but I couldn't start a debugging session without closing all chrome windows and exiting the application first

 

Shutting down Chrome is required when starting Chrome with your custom profile - see https://www.jetbrains.com/help/webstorm/debugging-javascript-in-chrome.html:

"To open a new Chrome instance with your familiar look-and-feel, configure Chrome in WebStorm to start with your chrome-user-data. In this case, before starting a debugging session, always make sure that Chrome is not already running with your chrome-user-data. Otherwise WebStorm still launches another instance of Chrome with your chrome-user-data but is unable to open a debugging port for it."

 

If you like to be able to attach a debugger to a running Chrome instance, you need using JetBrains Chrome extension - see instructions on activatuing it in https://www.jetbrains.com/help/webstorm/live-editing.html

0
Comment actions Permalink

There is no Live Edit in 2019.1 of PHPstorm

 

0
Comment actions Permalink

Hi

I installed Live Edit and I get the debug session opened in the currently opened browser, which is great.

Any particular preference on using the new approach of spawning a new browser instance with the custom profile? I honestly only need the live edit workflow to simplify the back and forth between IDE and browser with the app switcher, alongside with other browser tabs that might have docs, references, etc. Believe it or not having the same browser icon listed twice on the app switcher makes it a common mistake to switch to the wrong instance

Thanks!

0
Comment actions Permalink

I am using:

IntelliJ IDEA 2022.1.2 (Ultimate Edition)
Build #IU-221.5787.30, built on May 31, 2022
Runtime version: 11.0.15+10-b2043.56 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
macOS 12.4
GC: G1 Young Generation, G1 Old Generation
Memory: 1024M
Cores: 4
Registry:
    ide.balloon.shadow.size=0

Non-Bundled Plugins:
    com.jinsihou.react.snippets (1.1.0)
    com.intellij.plugins.xwinkeymap (211.4961.30)
    com.mallowigi (64.0.0)
    org.moe.community (1.4.10)
    intellij.prettierJS (221.5787.15)
    com.jetbrains.lang.ejs (221.5787.15)
    com.chrisrm.idea.MaterialThemeUI (7.5.0.3)

Kotlin: 221-1.6.21-release-337-IJ5787.30

I followed the `Live Edit` instruction mentioned in this thread, but still it opens a new chrome window without my chrome profile being active. Any solution?

0
Comment actions Permalink

Instructions above are outdated, as the  JetBrains IDE Chrome extension is deprecated and not suppirted anymore.

There is currently no way to attach a debugger to a running Chrome instance, because the IDE uses Chrome protocol with --remote-debugging-port option for JavaScript debugging, and a port for debugging can't be opened after browser is started.
Note that you can modify Chrome settings in Settings | Tools | Web Browsers and Preview to launch Chrome with your own user data (settings, extensions, etc.) instead of using a fresh profile - see https://www.jetbrains.com/help/webstorm/configuring-javascript-debugger.html#ws_js_debug_default_chrome_user_data
But, if you do this, always make sure that Chrome is not already running with your user data before starting a debugging session, it won't work otherwise.

0

Please sign in to leave a comment.