Scaling issue on Arch Linux, 2017.3 update

Answered

2017.2 and before I never had scaling issues. The 2017.3 update made every UI element just really big, except for the editor fonts. Icons, menu items, etc. are all big. This also affects the loading splash on first start - it is noticeably larger  than the 2017.2 splash was. I haven't noticed these issues on my other machines.

Here's IDE and system information:

IntelliJ IDEA 2017.3.1 (Ultimate Edition)
Build #IU-173.3942.27, built on December 11, 2017
Licensed to Minecraft Development for IntelliJ / Kyle Wood
Subscription is active until August 30, 2018
For non-commercial open source development only.
JRE: 1.8.0_152-release-1024-b8 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.14.4-1-ARCH

And a screenshot:


3 comments
Comment actions Permalink

This is probably because https://youtrack.jetbrains.com/v2/issue/IDEA-171404 was fixed.

Your system scaling is probably > 2. Try making the Appearance font smaller in the IDE Settings | Appearance (override the font).

0
Comment actions Permalink

It seems to be that IntelliJ thought the scaling was double, but it wasn't. Something to do with how Cinnamon handles HiDPI I guess. I had it set to Auto, which defaulted to Normal, which is no scaling, which is correct for my display. For whatever reason, though, IntelliJ was rendering for HiDPI. Manually setting it to Normal fixes the issue, and doesn't affect how any other applications are rendered.

0

Please sign in to leave a comment.