IDE Settings Sync not synchronizing keymap

I have the "IDE Settings Sync" plugin installed on two machines and my PhpStorm copy is connected to my JetBrains Account. My "slave" installation managed to import all the settings from my "master" installation, except for one of the most vitals: Keymaps.

I use a custom keymap (based on Default) on my main installation, but none of my keymap changes are showing up on my secondary install. I tried changing IDE themes and other things, and those are synced moments after I close the IDE on one machine and open on another, but no matter what I do, keymaps are not being synced.

Help?

9 comments
Comment actions Permalink

Hi there,

Is OS is the same on both computers? Keymaps sync only per OS (as per answer from the plugin page below)

 

Maybe better ask in https://plugins.jetbrains.com/plugin/9922-ide-settings-sync

1
Comment actions Permalink

Windows on one, Linux on the other. PhpStorm calls the keymap (Default Windows/Linux) on the docs, so I assumed they were the same thing for both systems.

0
Comment actions Permalink

Well .. as per that comment on plugin page the keymap is synced between the same OS only -- that's how I understood it.

0
Comment actions Permalink

> Well .. as per that comment on plugin page the keymap is synced between the same OS only -- that's how I understood it.

Absolutely awful... why is this?

 

1
Comment actions Permalink

Absolutely awful... why is this?

Because macOS and Linux/Windows machines have different keyboard layouts and different system shortcuts.

0
Comment actions Permalink

Absolutely awful. 

0
Comment actions Permalink

OK I manually copied my key settings to my Linux machine.

Then I installed a Linux copy of IDEA on another machine.

I now have 2 Windows IDEAs (they sync keymaps successfully).

But the two Linux IDEAs are not syncing their keymaps.

Why is this? You said IDEA keymaps sync across the same OS?

 

1
Comment actions Permalink

Ayqazi , try this:

On one of your Linux IDEA, duplicate your current keymap and re-name it to something like 'Ayqazi - Linux'. Now, wait for the sync and open your IDEA on your second Linux box, go to the keymaps and select 'Ayqazi - Linux' and you should be set.

Unlike Windows, which has only one pre-set, Linux has one for KDE and another for Gnome, so modifiying the base keymap can lead to some confusion, Making sure you are working with a named copy will fix this (at least it fixed for me on my two linux installs).

0
Comment actions Permalink

> On one of your Linux IDEA, duplicate your current keymap and re-name it to something like 'Ayqazi - Linux'. Now, wait for the sync and open your IDEA on your second Linux box, go to the keymaps and select 'Ayqazi - Linux' and you should be set.

 

Naming the Linux and Windows ones differently worked, thanks!

 

0

Please sign in to leave a comment.