System path '/Users/mac/Library/Caches/PhpStorm2017.3' is invalid. If you have modified the 'idea.system.path' property please make sure it is correct, otherwise please re-install the IDE.

Hi guy !

 

I settup phpstorm in mac but error.

 

My mac on high sierra version 10.13 

 

Thanks !

11 comments

Please remove ~/Library/Preferences/PhpStorm2017.3 and try again

0

Hi guy ! I deleted it. But it still has that error

0

Did you modified phpstorm.vmoptions file? Please try to reinstall the app as suggested

0

I do not have any settings.

I update version my mac and downloaded the installer from the home page but it crashed. I do not understand why

0

Did you have PhpStorm installed on this mac before? 

Try to delete /Users/mac/Library/Caches/PhpStorm2017.3 also (if the folder exists)

0

I tried installing under the document and following your instructions. But it still has that error. I still do not understand why. 

0

I have the same problem. I deleted the Cache directory, the Preferences and the one under Application Support. PhpStorm still will not start. Any ideas?

1

Yes I am still and I do not know why.

0

Creating the directory /Users/[myuser]/Library/Caches/PhpStorm2017.3 and chowning it to myuser:staff resolved the issue.

This problem showed up, after moving to a new mac with restored data from backup.

1

Thanks for sharing this with us

0

Hi all,

I've been having the same issue as Tam, but then for IntelliJ Community Edition. I'm also running High Sierra (10.13.3) and I've now had this popup come up for the second time. I noticed that ~/Library/Caches was now owned by root and was almost empty when this popup occurred.

The fix was to reclaim ownership like Fk mentions, but I'm more worried by why this happens in the first place. Does anyone have an idea what could be causing this? I tried Googling it, but all I can find are tutorials on how to clear your caches folder, which is the opposite of what I want ;-)

Thanks!

0

Please sign in to leave a comment.