Can't execute statements in PostgreSQL file. It thinks ::type casts are parameters

Answered

I just noticed that I can no longer use "Command-Enter" keyboard shortcut to execute the SQL statement before the cursor, when editing/viewing a SQL file. It pops up a window asking for "parameters", but it shouldn't do this - there are no parameters. It appears to be misinterpreting expressions like `foo::integer`, which is a type cast in PostgreSQL, as a call for a parameter ":integer".  This used to work.

Is there a way to fix this?

1 comment
Comment actions Permalink

Please remove `:(\w+)` pattern from Settings(Preferences on Mac) | Tools | Database | User Parameters settings or disable User Parameters at all.

When User Parameters are enabled IDE will detect certain sql symbol patterns as user-defined parameters in scripts (or string literals). You can change/enable/disable certain patterns for specific SQL dialects in that settings.

After recent update the User Parameters settings were not properly migrated, and this pattern was enabled. Sorry for inconvenience.

1

Please sign in to leave a comment.