Unable to set sbt heap size in IDEA

Hi,

I am using IDEA with the external SBT server for compilation, and I'm trying to increase the heap size to 1500MB.

I have set the heap size and the server options (as seen in the picture below)


However, when I start IDEA, the sbt shell is started with this parameters:

/usr/lib/jvm/java-1.8.0-openjdk-amd64/bin/java -agentlib:jdwp=transport=dt_socket,address=localhost:36104,suspend=n,server=y -Xdebug -server -Xmx768M -Didea.runid=2017.2 -Didea.managed=true -Dfile.encoding=UTF-8 -jar /home/marcello/.IntelliJIdea2017.3/config/plugins/Scala/launcher/sbt-launch.jar idea-shell

So I would like to know where the -Xmx768M option is coming from and how to override it.

Thanks.

P.S. I have also set -mem 1536 in /usr/share/sbt/sbtconfig but it doesn't help.

2 comments
Comment actions Permalink

Found it!

It's not under Compilers, it's under Build Tools > sbt

3
Comment actions Permalink

Mr. Marcello Barisonzi's comment is correctlly....

 

thank you for your comment..

i have been find this solution about this for 3 hours.... thank u ~~ 

0

Please sign in to leave a comment.